Multiple OSM Maps on a Garmin Montana Problem

Help please…

I have used osm2garmin to create several maps for several regions, they all display ok in Basecamp.

I have a strange problem loading more than one OSM map onto my Montana 600.

From what I understand you can have several .img map files in the /Garmin directory on an SD card.

OK, so I have loaded four OSM map files onto the SD card and renamed each of the files.

I can see each of the files in the Setup - Map option on the Montana, all are enabled.

I can see all the details for one of the maps, roads, contour lines etc. BUT… I can only see the contour lines for any of the other maps???

If I remove the map file that is working then one of the other map files works correctly, I can see the roads etc, but the others remaining only display the contour lines…

Anyone offer any help?? Please???

I’ve tried editing the map name with a Hex editor, that doesn’t help.

I’ve tried copying the .img file for the region directly to the SD card and also tried using Basecamp to transfer the map to the SD card, same difference…



Hi Nick,
this can be the result of one of two restriction of the Garmin IMG file format on Garmin GPS units.

  1. different Maps need a unique combination of FamilyID and ProductID of the map. i.e. at least one of the ID’s must be different for each map stored on the Garmin Handheld (The same is true for basecamp so this is probably not the case here).
  2. All file names of the map tiles i.e. the numbers given to all single tiles and the “overview”-map must also be unique globally, i.e. no tile number can be reused in another map also stored on a Garmin GPS unit.
    That means if a map you uses the number 62400001.img to 6240010.img for its tiles and overview map these numbers MUST not be used in any other map you intend to use/store at the same time on the Garmin GPS unit.
    basecamp seems not care about this restriction. So the maps appear to be correct if you view them in basecamp/MapSource but are not displayed or rather only one of them is displayed if both are on the GPS unit.


OK, thanks for the info.

The problem is indeed a conflict in the name of the tiles.

All the regions created by osm2garmin share some tile names that are the same, in the format of 70000001.img etc

Can’t see anywhere to change this within osm2garmin??