[mkgmap] All labels missing on Oregon?

Hi there!

I’ve downloaded Gribeco’s Japan map from http://admincabal.com/osm/ and installed it on my Oregon 450. Unfortunately, the maps show no labels at all. I also tried to generate my own map, but the text is completely missing on my map, too. Oregon is running software version 6.10

Any Ideas on this one?



Do you mean the streetlabels are missing?
It can help to do a hard reset to get the labels back.

I had the same (?) problem on my Dakota 20, while QLandkarte GT showed everything as expected (to be more specific: even selecting an element on my Garmin showed Lon/Lat values instead of their names). Dropping the mkgmap option “–ignore-osm-bounds” does the trick to me. So if you’re using this option, this might help.

It is a Garmin Dakota/Oregon bug related to a typ file where routable line labels are made invisible. I thought in the latest firmwares it was solved but you never know when it could pop up again. :confused:

Hey guys, thanks for your input.

Basically, I don’t have no text at all. I exchanged the font files(?) as described in Mkgmap/i18n and downloaded a japan.gtt to see if it could display Japanese characters at all (which it did). So displaying those characters in general seems to work.

But I don’t have a single string on the whole map, nothing is labeled. No cities, no roads, no POIs, nothing.

Do you have more information about that bug? Can I overcome the issue by using a TYP file that would avoid this bug?

That bug caused only the streetnames to dissapear, your problem looks like the Japanses characters won’t display. Better contact the map maker and ask for help?

I had the same problem on a “Western” Oregon 600.
I was able to confirm that the fonts I had installed did contain Japanese characters by

  1. decoding the font data files (xor 0x76) and viewing them with a font viewer
  2. installing a Japanese.gtt text translation file

The problem seemed to have been that my device can “only” display UTF8 but the map from admincabal uses SJIS. After downloading a UTF8-coded map from http://gpsmap.php.xdomain.jp/ everything works fine.