Max Heights not working


Max heights are well documented in my area. I’ve been using this bridge for my tests (Barley Cop Lane going under the railway).

Both my Garmin and OSMand fail to route accordingly, even with up to date maps. So it will happily route a vehicle of 5m under this bridge.

Any ideas how to start working out where the issue is? Interesting weight limits work find on OSMand in my area, for instance this road (Denny Beck bridge).

Thanks, Geedle.

I am not aware of an OSM based map for Garmin devices that is made for trucks, in other words, probably tags like maxheight are simply ignored. You can create your own map using mkgmap and that would allow to ignore those roads so that an alternative route is calculated.
If you have an OSM based map from Garmin you should ask Garmin for support.

In my experience OsmAnd will respect max height (if it is turned on in the routing options), however it could be an unit issue. I’ve only ever seen it work in metric units, so for starters I would convert to meters and see if it starts working then.

Carlos Davila has been making these maps for quite some time:

I know he made some maxheight edits in the UK, so he would be the person who would know if feet and inches values in maxheight are readily useable. (Personal gripe maxheight:imperial is a bad tagname as the largest country to have feet/inches values is the US which left the British Empire before the (British) Imperial standards of weights and measures.)


I’d tried with little success (device hangs on startup), but a gave it a go compiling my own map with mkgmap and it worked perfectly.

Many thanks, Geedle.