Mapnik only renders Points

I am installing my own openstreet tile server I loaded pakistan.osm.bz2 , romania.osm.bz2 from using osm2pgsql but when I rendered tiles It only shows points no roads,highways,streets when I explored the db I found out that planet_osm_line, planet_osm_polygon, planet_osm_roads tables are empty

gis=> \d+
List of relations
Schema | Name | Type | Owner | Size | Description
public | geometry_columns | table | haseeb | 8192 bytes |
public | planet_osm_line | table | haseeb | 0 bytes |
public | planet_osm_nodes | table | haseeb | 40 MB |
public | planet_osm_point | table | haseeb | 864 kB |
public | planet_osm_polygon | table | haseeb | 0 bytes |
public | planet_osm_rels | table | haseeb | 184 kB |
public | planet_osm_roads | table | haseeb | 0 bytes |
public | planet_osm_ways | table | haseeb | 13 MB |
public | spatial_ref_sys | table | haseeb | 8192 bytes |
(9 rows)

I loaded romania.osm.bz2 and also osm export from using osm2pgsql but the tables planet_osm_line, planet_osm_polygon, planet_osm_roads still remained empty and mapik only rendered points from the data not polygons,etc…Can anybody please guide me

I used to build my server (is now temporarily offline but Google has it in its webcache)

Please help me

This is very likely a problem with osm2pgsql’s usage of libgeos. My guess is that on your system you have either an old libgeos or two versions of libgeos. The problem here is that osm2pgsql is not 1) checking for a suitable version of libgeos (I think >= 3.1 is required) and 2) osm2pgsql is not throwing an error and rather is silently just not importing data.

The solution to this (when I’ve run into it) is to (re) install libgeos latest from sources, then recompile osm2pgsql. Then run:

ldd /usr/local/bin/osm2pgsql

and make sure that the output contains a reference to the libgeos library you installed which will likely be in /usr/local/lib/ …

the other possibility is that something is wrong with the cloudmade .osm extracts too, maybe try the ones from geofabrik to make sure that is not the issue.

Thanx springmeyer…I tried extract from geofabrik but the problem was stil there now I am trying your first solution about re instalation

I couldnt understand "and make sure that the output contains a reference to the libgeos library you installed which will likely be in /usr/local/lib/ … "

Thanx waiting for reply

Thankyou so much…it worked

I used geos-3.2.2 from