Mapnik installation?


my goal is to set up my own server but unfortunately I was not able to finish the installation process.

First I tried the following instructions on Ubuntu 8.04 (fresh install on a virtual machine with Virtualbox):
The installation failed at the PostgreSQL Installation. The workarounds in the comments did not word.

After that I tried it on Ubuntu 9.04 (fresh install on a virtual machine with Virtualbox):
Here the installation failed while executing a python script. A package called “Boost” was required with version 1.41 or later. According to the script that installed the depenencies I had version 1.35. I was not able to get 1.41 on the system (I found the boost homepage with V1.41 but I was not able to deinstall 1.35 and install 1.41; I am not very experienced with Linux)

The instructions at did not work either:
The package libboost1.40 could not be found.

Now my question is:
Is there any package for mapnik available with all its dependencies? It does not need to have all the newest versions, it just has to be working.

Or is it possible to manually install Boost 1.41 and modify the installation scripts?

Those instructions tell you to download the mapnik source from SVN. However, the current SVN trunk version is mapnik2, which is in development right now, and indeed needs boost 1.41.

You can continue using the older version (currently ramping up for a 0.7 release in a few weeks) by switching to or checking out the 0.7 branch, which is at:

Then you’ll be fine with boost 1.35, and you should be able to follow those guides.

Thank you very much. Checking out V0.7 worked fine, currently I am downloading the world boundaries.

I still was not able to complete the installation, I got stucked later in the installation process.

Today I restarted the installation and found out that branch 0.7 is not available anymore.

Could it be posstible to offer a package with a mapnik installation including all its dependencies?

In the meantime, mapnik 0.7.0 has been released, and builds are soon to follow.

The branch has been tagged, and thus moved to