Mapnik - contour relief maps render problem


i have problem with contour lines render. Can someone help me please?
I tried “openstreetmap-carto approach” and “The shapefiles approach” and result is none in both cases.
I do not know what is wrong. I have tried several mapnik.xml configurations with not result. Normal map layers render works fine.
I tried to view .shp files by and them looks good.
Do you have any working example of mapnik.xml with “The shapefiles approach” or “openstreetmap-carto approach”?
Do you now how can i debug contour relief render?

Best regards
V. Simek

Ways in DB are in format “MULTILINESTRING((9256201.75613365 6101692.23439377,9256155.41160973 6101661.44832044,9256124.5152759 6101692.23439377,9256099.79820883 6101830.77310613,9256155.41160973 6101900.04333369,9256195.13546751 6101830.77310613,9256201.75613365 6101692.23439377))”. DO you know how to convert it to something readable? I would like check if data are on right spot.

I have tried to watch data in pgAdmin4 and they look good.
After that i have tried to change min, max zoom level of one layer rule and it loaded several GB of data. Bud nothing were rendered.
I have tried multiple projection as 3857, 4326, 900**** in import and layer settings.
I am desperate. :frowning:

It is wokring! Bud it is a real mess. Contours are on wrong position (somewere at Kazachstan) and they are all at one position. Overlaping.
Wrong upload to DB
shp2pgsql -p -I -g way -s 4326:900913 $f contour
gdal_translate -srcwin 0 0 1201 1201 -a_ullr 83 49 84 48 “$f” “$f”.tif
gdal_contour -i 10 -snodata 32767 -a height $X ${X%%.tif}c10.shp

Omg. It is -a_ullr 83 49 84 48 parameter. Copy paste error.