map problem in spain, rio quadalquivir

I have a map from Spain, downloaded from raumbezug, dated 22.1.2012, which works fine. But now I tried to load from the same source as well from another source ( a newer map for my garmin oregon. And there is now a problem as follows:
I download and unzip the file gmapsupp.img and install it in the garmin folder, look whith basecamp or in my Oregon to the aerea between Sevilla and Cordoba. there i see a big blue gusset, about 150 km wide, in some downloads between sevilla and cordoba, in others more east of cordoba.
The north edge of this gusset is the border of the river quadalquivir, the south edge a straight line between two points about 150 km distant, so that the river quadalquivir is shown as a big lake with roads and villages in it.
This happens with basemap under windows XP as well as under windows 7 and also direct in my Oregon 450.
I looked in the open street map itself to the position, where the edges of this gusset are, but I can’t observe there any irregularity, especially no change of any property in 2012.

It reminds me of a topic discussed in the mkgmap mailing list last year: a region of Wales was flooded because someone tagged an island in a lake with natural=coastline (see The use of multipolygons for such islands is far to complicated…
I’ll investigate, perhaps I can find such an island in your region.

That is something different, and I do not know how to fix it:
There is a “multipolygon” with the name “Río Guadalquivir” ( It contains the (central) way of Río Guadalquivir and some of its tributaries, but also some reservoirs. Due to the open (non-connected) lines, that “flooding” appeared.
I tried to change the relation type to “network”, but I am not content with that, because of the areas contained in the relation. When trying to upload, I received quite a lot of validation errors - and look at the comment for the last changeset: “Validation errors fixes”. Hence I do not upload my change, the problem remains.
I will enquire n the German forum, as there are several experienced mappers who might find a solution.


Problem fixed: I moved the ways used to describe areas into a new relation (2053787) of type multipolygon, and changed the type of the original relation to collection.



The same problem appears around the area east of Ubeda. Half of the Sierra Segura is covered with water!


Netzwolf fixed the data last Sunday afternoon. The data are correct now. I just downloaded freshly from velomap (, the problem has gone here. Perhaps you need to download your map again, take care that the map has been updated very recently.