Map download no problem, but now cannot open

Hi, I am new here. I downloaded one single map as a test. About 10mb. It went fine. Got it on Mapsource and onto my Garmin 76csx. tired a larger section of North america. About 857mb. It took 4 hours and said it was complete although it read only 821mb. when i try to run it a message comes up saying “the installer you are using is incomplete or corrupted”. Any thoughts as to what I may be doing wrong? Should I be downloading a smaller file? Any help would be appreciated. Thx

Which provider for the Garmin maps did you use?

I used The mistake I made was trying to download them with wifi instead of a cat5 wire connection. By using the hard wired approach I was able to get it work. However only one of 3 mapsets I tried was complete One set was incomplete (about half the maps) but otherwise fine. The 3rd set of maps would not convert in gpsmapper and gave me a Error 017 ‘cannot parse’ message. It said it was on mp802. I had no map by that name.
Thanks for your help. I 'm getting close.

Ok, things start getting fishy if wlan starts producing different results over wired-lan. There should be no difference. Is your pc perhaps overclocked?

Can you give a link to a map that didn’t work for you?

It is expired but this is the one that would not convert in gpsmapper (error E017)
The WLAN download speed is much slower on my internet than wired LAN and I think it was losing the connection and aborting the download. THX

Unfortunately that map has already been deleted. You say you “convert with gpsmapper”, what do you mean with that exactly? Are you using sendmap to combine maptiles into a mapset and send the result to the gps? Or do you really use cgpsmapper for some proceesing? Can you elaborate?

Hmmm. I don’t really know what I am doing. I am trying to download the tiles into mapsettool which seems to use gpsmapper to convert the map into a usable format. Then I load the into mapsource and then into my Garmon 76csx. Of my 3 mapsets I downloaded one was complete and everything went perfectly. One set was incomplete (about half the maps showed up) but otherwise fine. The 3rd set of maps would not convert in gpsmapper and gave me an Error 017 ‘cannot parse’ message. It said it was on mp802.
I am following this process

There’s no need to use MapSetToolKit or cgpsmapper for this (and they might not work anyway).
When you get emailed the link to download the map, just download the one named “osm_routable_mapsource.exe”. Then run that, and follow the instructions, which will install it in Mapsource.

Ok. But if I do that I cannot load more than one mapset because it all gets automatically named the same and erases the previous mapset???

Correct. If you want to install multiple simultaneous maps in Mapsource, you will need to change the family IDs of the maps. You might be able to do this with gmt.exe (I’ve never tried). Alternatively, create your own maps with mkgmap then you have all the freedom you want.

Below the slippy map on my website you will find a manual for installing multiple Garmin maps with the same ID’s in MapSource.

Well, I sent in a new request for maps and tried it again. It worked perfectly this time and I loaded the different mapsets into Mapsource using Maptoolset. Was able to load them into my GPS and its all good. Thanks for all your help and a great site.