Made road un-routable... need help fixing it!

I managed to make the residential road into my neighborhood un-routable, and need help fixing it. The residential road Colvos Drive Northwest leads into our neighborhood, and used to be routable. However, I just discovered that it is no longer routable from the intersection with Sea Cliff Drive Northwest. I made some changes about a month ago to make the roads more accurate, but somehow it has become disconnected, and I can’t figure out why.

The intersection is at the node shown below. I didn’t make any changes to this particular node, but I made changes to nearby ones. I just tried deleting Colvos Drive Northwest and re-mapping it, but that didn’t fix the problem.

Any help fixing this would be much appreciated.

Node: 110936996
removal of unnecessary TIGER tags for Pierce, WA (as discussed on talk-us) (in progress)
Edited over 6 years ago by woodpeck_fixbot
Version #2 · Changeset #3313948
Location: 47.359427, -122.555472
Part of

Sea Cliff Drive Northwest (416591827)
Sea Cliff Drive Northwest (12246261)

The node is

Well, you re-created that way only a couple of ours ago. Give the routing engines some time to update their databases. That might take a couple of hours/days.

In general it is not a good idea to just delete a feature and re-create it. That way all the history of the feature is lost. Better, next time ask first before deleting. Now it is also difficult for us to find out what the problem was in the first place and how to avoid it in the future.

Here is the link to the road in question. I’m not sure why the node above goes to the wrong place.

The problem is still there. If anyone can help me figure out why this road is un-routable, I would much appreciate it. Thanks in advance!

In which routing engine is it unroutable? OSRM can route along a section of what is presumably the road that you deleted: .

It doesn’t seem to be routable in any search engine. Of course, it’s routable along itself, as you’ve shown, but you can’t route to or from that road from anywhere else:

There is a problem with the connection between Sea Cliff Drive Northwest and Colvos Drive Northwest.

Seems to work for me Screenshot of your last URL

OK, that is really, really strange. It works fine, now. Previously, the purple route line would simply not go down that road. Problem solved.

How did you post a screenshot, by the way? That would be really useful at times.

Not strange at all. As I wrote earlier the routers have there own databases which are not immediately updated after changes to the OSM database. It simply takes time after you made a change to the map that the routers are aware of it.