Macintosh -> install WMSPlugin ???

I use JOSM on a Macintosh (iBook, Leopard).

I’m new to OSM and to JOSM. I did some tests and improvements on my home area, and I would like to test also Yahoo aerial maps. I install the WMS plugin on JOSM, but it seems that isn’t enough. I found an installation procedure on the Wiki, but it seems to be a little complicated (install Xcdode, install Qt…). I don’t want to develop anything, just display Yahoo satellite pictures with JOSM.

So, is there any simpler way to do this than install all the tools listed on this page ? :

Thanks in advance for any help !

I’m afraid installing the yahoo downloader is rather complicated

This is one area where Potlatch is massively easier. Potlatch is the online flash editor (“edit” tab). Have you tried that? I think it shows Yahoo by defualt, but otherwise it’s easy to change the background to show it:

Yea its complicated. I succeded once… but now something is broken and I reall, really want it to work! I guess its my webkit thats not installed in the correct location. Can anyone see if its in the right location or not?

My problem is the webkit dont show in the meny (how do I change to english language?)

I put it here:

Or is it my paths that need some love?



my webkit-image is in /usr/bin - this works fine.
However, it should work also in some other directory, as long as it is in your $PATH. To check this, open a terminal and type “echo $PATH” (sorry if you knew that).


Thanks Lars Vegas! That means I need to look for the solution else where.

Well, a simple way is to just copy your webkit-image to /usr/bin and see whether it works. Or what do you mean with “else where”?


I mean the problem seems not to be with the placement of the webkit-image. As I did put it in /usr/bin and it dont work. :frowning:

After countless hours of desperately trying to get the WMS plug to work, Im giving up. I still get the “Exception occurred red tiles” error.

I have followed the instructions on the Wiki, but still no joy. Can anyone help me out?

I can’t help you, but I can at least assure you: You are not alone! I have the same problems. Dont belive anyone who says its your fault. I software doesnt work it’s not the user’s fault it’s the designers fault.

Booted my Mac in XP-mode. Installed JOSM+WMS. Worked like a charm! To bad I cant use it in OSX mode.

^You can. Just download this file:

This will install the qt files you need to run the wms plugin. (Note, I had to install the packages individually as the main package installer kept crashing, but this is easy to do.)

You also need to have installed XCode which is free from Apple.

You might also have a look at Merkaartor. If you download this version:

(which also requires the qt file referred to above) it has built-in support for Yahoo aerial photography.

IMHO it is a superior editor to JOSM. But, that’s just me…

Installed XCode + QT files + latest JOSM and WMS. But it does not work.

Downloaded Merkaartor. Looks sweet! And works with the Yahoo pictures too! Will have a go with it today. (Is there a way to create 90 degree angles? I use the area tool “x” in JOSM all the time.)

What, exactly, does it do?

I haven’t found it, but I’m just a beginner as well.