Lock zoom level -JOSM


I was tracing an area with Potlatch when I realized that level 18 zoom is newer than level 19 (both zoom level doesn't match the highways very well, off by a few meters). If I switched to JOSM, is there a way to lock the image layer at zoom 18, and then increase the zoom? (it may be pixelated, but I prefer to trace on latest image).


Go to JOSM settings about WMS / TMS.

there you can thee the “URL” for many WMS or TMS services. You can define the maximal zoom level with e.g. [18]

About Bing images, I can see [22] today … change this to 18.


Or right click the image and untick something like “auto-change zoom-level” (I’m using a non-english locale).


Thanks, that worked in JOSM. (as long as I remember to activate that option!). Especially helpful since Mapbox made their imagery available at zoom level 17.