Legend HCx: Rendering trouble with pre-built OSM


I am trying to use the map provided here: http://wiki.openstreetmap.org/wiki/User:Computerteddy
labelled “Germany complete and ready to use for your GPS device”.

I copied the file to my Legend HCx.

And then I found my home is displayed to be lying in a huge blank spot. When I scroll a few miles to the right or left, or zoom out, some details appear, which disappear again when I scroll back or zoom back in. Sometimes, only about the left half of the screen is renderend, and the right half stays blank. Some areas can be tricked into being renderend by scrolling back and forth, but some areas (like my home) just stay blank.

I have not yet discovered a pattern in what is displayed and what isn’t and when, although Tile borders do not seem to be relevant.

Has anyone seen this problem before?

BTW, I have also tried the CloudMade map of Germany. I encountered a different problem there: All the roads which I understand should be highlighted because of missing names etc. are in fact not displayed at all on my machine. Everything else is displayed alright.

Thanks for your time!


I cannot see what you are doing, but a simple copy won’t work. The files you refer seem to be compressed and I am not certain whether you can decompress on a Windows computer (will certainly need a dedicated programme).

if the files are decompressed you can load them into your GPS Legend with the Sendmap20 programme. This can be downloaded for personal use here: http://www.cgpsmapper.com/ (scroll down quite far for the Free downloads section)

Sendmap allows you to load more maps at the same time, you need to combine them all in the Sendmap interface.

Success, H


thanks for replying: The files are .tgz-files, which my old Mac gracefully unzips.

I copied the gmapsupp.img to the Garmin-folder on the SD-card. The device displays the copyright message of OSM and lots of roads, so it seems to be recognized allright.

The strangeness starts only afterwards.

Can my problem still be related to installing/decompressing? Am I simply out of luck and need to get the whole toolchain to try and make my own gmapsupp.img?


It may has something to do with the building of the tiles. I noted possibly something similar when I did build Calgary in Canada my self and found that a number of streets were missing on my GPS. They are in OSM, but did not copy to my legend HCx. I thought it had something to do with missing street names (I used MKGmap 5.90), but may be there is a different issue.

A test you may want to do is copy the NL map from here: http://garmin.na1400.info/index.html to your device. It is used for many months now and I have nor seen nor heard this kind of issues.


Yes, here in Delft (NL).
52.00346 N
04.35254 E

Tried twice with maps of different dates…
My source atm:

Garmin Etrex Legend HCx



Remy, is your reaction meant to confirm that the maps from http://garmin.na1400.info/index.html work?

Quite the opposite, sorry to say. Just now done another test.
No improvement :frowning:
Outside these “blackspots” it works fine.
Could it be a boundry between two tiles? It’s only on the lower zoomlevels…

(added some info/thoughts)

On the website of ComputerTeddy there is now a remark on "gaps between"tiles which should be remedied. Worth checking again?

You mean the new tilesplitter? I’m not (yet) making my own garmin maps :roll:
I don’t know what Lambertus is using… Site didn’t say…

My site is not using the new tilesplitter yet. I’ve done some tests with it, submitted some improvement ideas, but did not have the time to really use it in my build scripts yet. So currently, the ‘gap problem’ still exists for http://garmin.na1400.info.