Lac de Neuchâtel


I downloaded the Switzerland data (shape file) from geofabrik and I imported them in ArcGis.

I’ve got a problem, the “Lac de Neuchâtel” is not here unlike the “Lac de Bienne” which is here ?! I took a look on OSM and both of them are there…

Do you know why the “Lac de Neuchâtel” dosen’t appear in my Shape file ?




J’ai téléchargé les données Shape de la Suisse depuis le site geofabrik et les ai importés dans ArcGis.

A ma grande surprise, le Lac de Neuchâtel n’apparait pas tandis que celui de Bienne est bien présent… Pourtant, en regardant sur OSM, les deux sont là…

Est-ce que vous avez une explication a cela et comment faire pour y remédier ?

Merci !

@RBA… Thanks for your Information… I will check it.

@RBA… The problem is, some programms can’t show multipoligons correct. The Lac de Bienne is just a “Way”, so it will be show correct. But the Lac de Neuchâtel and Lac de Morat are multipolygons :frowning:

I tried to do something yesterday evening. Can you please check, if the Lac de Neuchâtel and Lac de Morat will be visible at you now? Thanks…

Yep, it worked ! Thanks efred !

By the way, how did you correct that ? You merged all multipolygons in one polygon ?

The result in ArcGis →

All right… so it works. Thanks for your test.
I made something, what’s not really “nice”. I put a “simple” way with the tag “natural=water” over the MPs… it isn’t really a nice solution, but like this, all programms can show the lakes.

It’s not nice indeed. What should a doubly drawn lake be good for? If you can draw it with a simple line, you don’t need the multipolygon and vice versa!

Obviously someone thought that a multipolygon is needed, so you should check first what it is used for. If the multipolygon has to be used to represent something in OSM and ArcGIS can not handle multipolygons - screw ArcGIS (or change the shapefile export algorithm). Becaue if it’s allowed in OSM, it will be used. Next time it’s maybe a forest with a clearing in the middle or something else that’s not so obvious like a big lake…

In this case, the multipolygon is also used to draw a breakwater near Faoug - which is gone with your simple way.

Luckily the Murtensee is just divided in to a multipolygon because of the boundary-ways - which should be tagged as a separate way anyway. So I corrected both, the boundaries and the lake. It should be correct now in OSM and in ArcGIS.