Kendzi3D - 3D Viewer as plugin for JOSM.

This looks great congratulation.

Does Kendzi3D plugin work properly now? It crashed at my computer some time ago, but I decided, that it is local bug in my computer, but just right now one our college wrote me, that he also had problems with Kendzi3D plugin.

My problems: I go to settings in JOSM, mark kendzi3d, kendzi3d-jogl and log4, press “OK”, restart JOSM. Go to “3D” - Kendzi3D View - nothing happens. I mark “autostart” and restart JOSM, in this situation I see a sign like “trying to load kendzi3d, it is impossible, do you want to disable kendzi3d?”. The sign is exact, because I write here translation to English (I see sign at my local language).

Our college has sign “Your security settings have blocked an untrusted application”, when trying to start kendzi3d plugin. He tried to decrease security level of Java, but kendzi3d doesn’t work.

In there was change in JOSM api in version 7575. I adjusted plug-in in the release 1.0.180. Please check if you have that version installed, if not update it. You can do it by Menu > Edit > Preferences > Tab Plugins > Button “Download list” > Select kendzi3d plug-in from list > Button “Update plugins”

If it won’t help please send PM with console output as described here.

User Andrei Maneasa from the University Brasow in Romania has programmed under my and Kendzi care following plugIn:

I hope, this plugIn can make 3D mapping more comfortable.
Of course, this is not the end of the develping:
More features should be realized in the next months.
Thanks for the user Kendzi for support and the company Elektrobit for financial powering of this development.

By the way: I spoke at the SOTM 2014 about S3DB 2.0.
The description in Wiki comes soon.
Improved Kendzi 3D should support these elements.
I hope everybody of you will have more fun with the work work with S3DB 2.0 because of more flexibility in 3D modeling with.

I released new version of application. New futures are:

  • new selection, now highlighting is made by outline not as ugly bbox
  • new editors. Now they are always the same size on top of object, so no longer hidden editors
  • editor could be highlighted when mouse is on it and it could provide some more information like height of building
  • new editor for height of building roof

This release contain massive re-factor of code so it is quite possible that there are some bugs there. If you find them please make bug report.

Hy, i’ve used the plugin the plugin the first time since the update.

Now there is that problem: (on a macbook using Yosemite)

If the plugin is started i could not select more than one node or way by holding the shift key. only the last node is selected then. if the plugin is not started, josm works normal.

The problem exist since some weeks both in Windows and in Linux.

Sorry for that, I will fix it as soon as possible.

Great :thumbsup:

Plugin should be fixed in version 1.0.184. Please check it.

Done with “Windows”. Now there is no longer a problem. Thanks for the fix.


Is it possible that the roof:orientation:across/along is not working good?
When I use I see in Kendzi 3D view along in F4 map as across .
When I use along I see in Kendzi 3D view across F4 map as along.
I think that Kendzi 3D view is wrong? Or are there other tag that overrule it?

When I use Kendzi 3D view height it is written with a “,” comma example “height 3,5” josm validation asks a “.” dot where can I change it ?


The roof orientation tag is working correctly only for rectangle like buildings. When shape of building is close to square it may work unpredictable. So I need some example to check if it is working right.

Should not happen. Do you edit height by 3d editor right? I added bug request.

adress link in F4


I have check your location and looks fine for me.

From your image I see that you are using an old version of plugin. Why don’t you upgrade it to the current version 1.0.184?

In josm plugin I saw kendzi"d_improved … I thought this is the best…now I see 1.0.184 I upgrade


Please take a look at this picture:

It should help with the camera movement in 3D view.

Unfortunately I still get the message that “kendzi.josm.jogl.JoglPlugin was not found”. For that reason the plugin is not running. On the wiki pages I can read that kendzi3d-jogl and log4j are requred, however, I cannot even find “kendzi3d-jogl” anywhere.

So I wonder how so many users have simply installed the tool from the plugins list without issues. Any hint how to fix that?

Plugin “kendzi3d-jogl” was renamed to “jogl” it should be in version 1.1.0. But all needed plugins should be automatically installed after you chose kendzi3d. Please check if you have installed my version 1.0.196 of “kendzi3d”. Plugin named “kendzi3d_Improved_by_Andrei” as I known is no longer supported.

It should be possible to install my plugin without problems, I test it on few computers and never fount problems, except of outdated graphic drivers. So if wont be working please send output form console.