JOSM Validator läuft Amok

Moin,

ich habe gestern Abend nach dem Update auf Version 19096 feststellen müssen, dass JOSM anscheinend Amok läuft.

Der - laut Doku geänderte Validator - motzt jetzt “unbekannte Werte” bei addr:city, addr:street und addr:postcode an.

Bevor ich mich an die Entwickler wende, wollte ich fragen ob das bei Euch auch vorkommt.

Gruß
walter

Das hat mich vor einiger Zeit auch schon mal irritiert. Liegt nicht an der JOSM Version sondern an irgendeinem Preset, dass diese Werte mit Beispeil-Daten enthält.
Es gibt auch ein Ticket dazu, ich suche noch…
Edit: Bei mir war es der contact: Raum:
https://josm.openstreetmap.de/ticket/23571

naja, immerhin haben die Kollegen in diesem Bereich “rumgeschraubt”:


Das dir bekannte Preset-Problem ist eventuell wieder aus der Versenkung aufgetaucht.

Die Änderung zu #23652 kam von mir und hat nichts damit zu tun. Der Knoten 3053091149 erzeugt bei mir nur die Warnung

  • craft=yes is unspecific. Please replace ‘yes’ by a specific value. (1)

Klaro, Meldung kommt nur, wenn man im Validator “Unwichtige Mldungen anzeigen” aktiviert, Das hab ich aber vor einigen Wochen und nicht etwa gestern gemacht, weil das für die Klärung bestimmter Probleme vorgeschlagen wurde.

Nun denn, Ticket ist raus: #23713 (Again: Meaningless informational messages for addr:* tags) – JOSM

Ich habe die unwichtigen Warnungen aktiviert, aber keine externen Presets.

Leider fehlt in dem neuen Ticket der Status Report, in dem die verwendeten Vorlagen aufgelistet wären. Du wirst also entweder selber nach der schlecht gemachten Vorlage suchen müssen oder evtl. findet sich eine bessere Lösung auf der JOSM Seite. Ich selbst werde in den nächsten Monaten keine Zeit zum Programmieren haben.

Hab den Übeltäter gefunden:

Wenn “Werte überprüfen” aktiv ist, motzt er (seid gestern)

Den Craft-Error hab ich inzwischen erledigt.

ps: Wie heisst das Teil denn auf Englisch?

Toll, dass du das Ticket geschlossen hast. :frowning:

Wie erklärst du denn, dass diese Meldungen erst seit der neuen Release wieder auftauchen? An den Einstellungen (und Presets) hab ich seit Wochen, wenn nicht Monaten rumgeschraubt.

Das ist nicht der Übeltäter. Der Fehler liegt in einer Vorlage, und dieser Test kommt mit der fehlerhaften Vorlage dann ins Stolpern.
Sinnvoller ist es wirklich, die Vorlage zu korrigieren, ansonsten kommen vermutlich auch für z.B. falsch geschriebene Werte wie residental keine Warnungen mehr

ok, aber warum kommt dann im Log keine Info darüber, welche Vorlage das ist? Selbst im Debug-Log steht darüber nix.

ps: ich klinke mich jetzt aus, da ich noch anderes zu tun habe

Das Ticket wurde als duplicate “geschlossen”, damit wird beim älteren die Dringlichkeit erhöht. Du kannst aber gerne die fehlenden Infos ergänzen, das geht weiterhin.