JOSM my gpx is not time-stamped

Hello, I’m new to JOSM by I need to work with this program for a projet.

I have a picture in jpg format with some EXIF information (time, position)

I want to use JOSM to insert that picture in my plan, but the built-in AgPifoJ program says that my picture is not time stamped (“La trace gpx n’est pas horodatée” in french). My gpx file is created by OruxMap on an Android phone powered by CyanogenMod 7. OruxMap allows to take pictures with the camera, and I think it is the same program that writes the EXIF information in the picture file.

I use:
Windows 7 SP 1
JOSM 4667
Java 1.7.0_01

The content of my gpx file is:

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>






<om:oruxmapsextensions xmlns:om=“”>
<om:ext type=“IMAGEN” subtype=“0”>/mnt/sdcard/DCIM/Camera/1325858439546.jpg</om:ext>

Can you please tell me what is wrong ?



I found the mistake: for JOSM, timestamp must be inserted in a tag. Not in a tag.

If the position is in EXIF, just open the images directly (File > Open). The gpx should work as well, you can write a bug report ( and attach all the files (image and gpx).

With the Explorer I can see the details of my picture:
My Exif is version 0220 and I have lat., long. and alt. coordinates in the ‘GPS’ section.

When I do File>Open and select the picture, a dialog box appear and is asking for the GPS file

@sebval, you could try to convert your gpx at Use convert - input gpx, output gpx and under options specify a speed value. The resulting gpx contains time stamps. Or is this not what you mean?

I didn’t know about Thank you for the information. I don’t understand about the speed: there is only one point in my file. What does the speed mean ?
When I convert the original file (produced by the OruxMap program), it generates another gpx than I can save on my compture. By JOSM says: "It’s not time-stamped :
here is the content of the generated file, with a speed of 10:

<?xml version="1.0" encoding="UTF-8"?>



Waypoints__20120108_1944gpx on


Waypoints__20120108_1944gpx on


Your gpx-file contains one waypoint, while I was assuming it was a track trace (did not look in detail to your original content). In some instances when a tracktrace contains no timestamps for all trackpoints, for example after editing in Garmin Mapsource, the gpsies trick is the way to attach again timestams at all trackpoints. Setting some speed value does the trick as was told to me (didn’t experiment what the result is when leaving it out). Conclusion for you is that the gpsies trick doesn’t help you. Sorry.

I can edit manually my gpx file produced by OruxMap, transforming the in . In fact to make it work in JOSM, i simplified my OruxMap file to leave the strict minimum and changed the waypoint in trackpoint. This is a problem if I have a lot of files.

Does anybody know an Android program that is fully-JOSM compliant in creating gpx files ?

There is OSMTracker:, and Locus ( works also.


Thanks for the links, I downloaded and installed, I will try them.