JOSM imagery not working

I am using the latest JOSM (5267), but have been seeing this for the last several versions. I run Linux Mint 9, if it makes a difference.

The imagery layers don’t work properly. If I try to show an OS Open Data layer, for example, it displays a completely different and unidentifiable piece of map, at the wrong scale and repeated tile fashion. I’ll do a screenshot if it will help. Is this a known problem? I have had a look through the JOSM active tickets, but can’t find anything similar.

Please open a new ticket and write a bug report.

So, as you have seen, it seems to be specific to this machine, so maybe it is better disciussed here. For others’ benefit, I also have a problem with some imagery not displaying correctly. I’m now running JOSM version 5356. I have tested on a laptop also running LM13 and JOSM, and it works fine. The same JRE is used on both machines (openjdk-6-jre). I have tried openjdk-7-jre but the behaviour is the same.

Tried Oracle JRE from instructions here, but get a 404 not found on the repository. Any other ideas?

So nobody can help?

Try deleting your preferences directory? See

Woohoo, that did the trick! Thank you. It is now working normally.