JOSM - How to make available default imagery work?

I’m trying to use any available default imagery for Taiwan in JOSM, as the bing aerial is patched with clouds especially in the mountainous areas, and the other active default sources contain no data for Taiwan. There are five selections available:

  1. NLSC Open Data WMTS

  2. Taiwan e-Map Open Data

  3. Taiwan e-Map Open Data with Contours

  4. Taiwan Land-Section Data

  5. Taiwan Village Boundaries
    The last two sources are not particularly useful for map editing, so I’ll focus on the first three.

  6. NLSC Open Data WMTS - after selecting it, the following pop-up appears: “The layer NLSC Open Data WMTS does not support the new projection EPSG:3857. Supported projections are: urn:ogc:def:crs:EPSG:3857. Change the projection or remove the layer.”
    Question: Is it possible to change the projection as recommended? How? Can I do it myself (e.g. editing file) or is it up to the web admin?
    I noticed this problem is common to other locations (e.g. Czech or Germany). Can JOSM address this issue in the future or do the imagery sources need to change?

  7. and 3. Taiwan e-Map Open Data and Taiwan e-Map Open Data with Contours - they load and align properly, yet they are practically not zoomable. Which is a great shame, since the default zoom of the loaded tiles is around 350m (as seen in JOSM), so the only visible details are major roads or rivers (the only useful items are mountain peaks). I said ‘practically’ not zoomable because, as little consolation, it’s possible to… zoom out. One can hardly think how to use this feature. The website where this imagery comes from allows zooming to 30m (as seen in JOSM), which would allow very comfortable editing.

Any ideas how to make it work?

Did you already some parameter switching in JOSM prefs?


alternatively: Have you QGIS installed? and can you load those WMS layer in QGIS?

I looked at the preferences>map settings>map projection but the projection supported by NLSC Open Data WMTS (urn:ogc:def:crs:EPSG:3857) is not on the list, and I don’t know how to make a custom projection.
I haven’t checked it with QGIS, but there is good news. After some time spent with preferences>imagery preferences, I managed to make Taiwan e-Map Open Data work, though not directly. I copied the link to Taiwan e-Map Open Data from Available Default Entries and pasted it into a new WMS (‘add a new WMS entry by entering the URL’). I clicked on ‘Get layers’ button and received a list. The list contained many more links than the Available Default Entries provided for Taiwan (including a perfectly clear aerial imagery of Taiwan), and most of them are genuinely zoomable. All that was left to be done was to make links to those most useful ones, and now I can access them form the imagery menu. It turns out that the Available Default Entries link to some less useful imagery sources than they could, and I would re-link them myself, but the Available Default Entries are not editable. That’s a minor problem, though. It’s also great to be able to tick the ‘Store WMS endpoint only’ box, as it gives access to less frequently (but still very useful on some occasions) imagery sources.