josm does not open files

Im trying to open an osm file with JOSM and its telling me that its parsing OSM data,after a few seconds this window disapears and nothing happens,even not an error…
The file is OK,I know that because i edited it many times.
Also,I tried to download another OSM file from geofabrik and still the same problem.
i can download data inside JOSM,but that is not what i want to do…the problem is just with oppening files with JOSM.
any suggestions?


All OSM files are not similar and JOSM needs some metadata tags which are not included always. At least “version” is such. Check if your files contain something like

However, if you have edited your own files with JOSM before this should not be your problem.
A wiki page with a weak connection to this issue:

It might be far too big to be loaded in JOSM! It looks like nothing happens, JOSM is just trying to load the file, but the memory it can allocate is too low, and thus the application seems to hang.
When calling JOSM via command line with extra settings for the memory, I can load a Geofabrik extract of e.g. Saarland within a few minutes (!) on my quad core computer with 8 GB RAM. And then it is hardly reactive…