Issues upgrading JOSM

That could be the problem. But upgrading JOSM also fails, whatever I try.

Upgrading JOSM is off topic, so, please, create a new topic or a new JOSM ticket using Help → Report Bug. We need as detailed information as possible about your system like current JOSM version, OS, current Java version etc. .


Those words were merely a part of the conversation. I have tried upgrading several times before and am certainly not going to try it again.

1 Like

Like @skyper said, upgrading JOSM is off-topic.

I have no clue why upgrading JOSM is failing for you (please file a ticket, see skyper’s comment above), but in order to fix your problem with authentication, you must upgrade. It is not optional (since we do not backport any changes to older versions). In order to continue editing with JOSM on OpenStreetMap, you must be running JOSM r18650 or later. The first “tested” release after that was r18678 (released 2023-03-02, AKA 15 months ago).

We do need to know the OS, current JOSM version, current Java version, etc. in order to troubleshoot why the upgrade is failing. There are a few “known” issues with some operating systems and installation methods.

For example, a few years back, the Windows installer had a change that was not backwards compatible; the fix for that is to uninstall JOSM and then reinstall it.

Another “known” issue is that there isn’t a finish screen for the JOSM Windows installer. The install succeeds, but the user doesn’t see a success message.


Perhaps the problem with installing JOSM is not as big as I thought. The problem that I had was probably caused by the fact that the installation guide does not explain that the JAR file is for Windows only and not for other OS’es. Scrolling down however revealed that other OS’es are also dealt with. I didn’t know that. I have always used “apt install josm” and this has worked for years. But not anymore because it doesn’t upgrade.

I consider this unintended sub-thread to be “solved.”

If you’re on a linux like system, have a look at which is an elaborate script to check and download the latest or tested version (as configurable, also keeps backups of former versions) on startup. The JOSM from distribution specific packages is often behind the current version (at least for package managers / sources I am using).

I’ve always used the .jar file on other OSes as well. A distribution mechanism like “apt install” is great if you don’t trust the software author and want some other testing first (I wish that Windows had something as good rather than third-party approaches like Chocolatey or Microsoft’s attempts). However, in the case of JOSM I do trust that something that appears at has actually been tested, and is a better option than whatever was bundled with the OS.


That is completely wrong. .jar files should work on every system with a working Java JRE (Version 11 or higher). Even the Linux packages include it together with some helper files.
Please, do not continue to post off-topic. We are trying to help you but, please, do what we asked you above (#29 and #31)

1 Like

The “official” Debian-based packages from JOSM repository have a tested and a latest version which can both be installed at the same time. Before trying some third-party script (no offense) which will likely reveal the same problems, I would first try the “official” version.

1 Like

Well, Tux is mutating into a lot of different species. E.g. the official Debian package is usually only a bit older (from the backports repository) and better tested than the versions directly from JOSM but e.g. Ubuntu does not include it and all that snap stuff makes it even worse.

I have never asked for any help on this topic.

May @mods-general please move posts from OAuth 1.0a and HTTP Basic Auth shutdown - #28 and below to separate linked topic, titled e.g. “issues upgrading JOSM” or similar, as those are unrelated to Oauth/basic_auth issues discussed in this thread? Thanks!


Moved to Issues upgrading JOSM