Is the Map available?

I’m very much a newbie, and having problems getting the map to load. Is the server just far too busy or am I doing something wrong? I get a message to say 38 items still to load - but they never do.

Thanks for any advice,

Hello Stuart, welcome :slight_smile:

What map are you talking about? Is the map on:

Please elaborate…

PS. All maps on the list above work fine at the moment.

Hi Lambertus,

I think there’s a problem with my Internet Explorer set-up. I’ve just checked on my Linux machine and can access the map at without any problem.

But maybe you could answer another question. I uploaded some gpx data a couple of days ago, and it doesn’t yet appear to have updated: it’s still pending along with more than 19,000 other uploads. Or am I misreading that?


Perhaps JavaScript is disabled in IE?

Your observations are correct. Processing of uploaded GPX files has stopped, so the latest ~1000 are stil in PENDING state. This is an issue that is being talked about and which should be fixed in the next couple of days.

Another problem with the tracklogs is: that since we changed to a new web-frontend the database structure has changed as well causing the old tracklogs to be deleted. They are scheduled to be re-imported, but in light with the problem described above, this has not happened yet.

The project is growing rapidly and we are experiencing some problems due to that.


The IE problem is to do with OSM, and I think its currently being worked on.

You don’t have to wait for your gpx file to upload, you can open it from within josm of your own computer, but just remeber to download before creating roads…common mistake people make when opening files locally.

I’m definatly finding the old data not being avaliable a big problem, it takes some time to find wich gpx file has the data I’m looking for, and then I have to open it in its entirety. It’ll be very appreciated when that is working again.

Thanks, didn’t know that.

True, the backlog of importing GPX files is causing raised eyebrows and lots of questions with newbies. Although JOSM seems to have no problem loading all my GPX files when I can’t find a specific one. Kinda brute-force but it works :slight_smile:

Hello again, I think I’m making a bit of progress. I’ve opened my GPS tracks in JOSM as suggested by Ben (thanks Ben), I’ve done a bit of editing and I’ve uploaded the resulting GPX file. I guess that upload is waiting in the same huge queue? So is there another way to render the file I’ve edited? I’m fishing in the dark at the moment as I can’t check that my edits make something that looks like a streetmap.

And just so you know, the area I’ve done a bit of work on is around Wath on Dearne in South Yorkshire - which is completely blank so far.


Only some of the uploads get picked up and stuck into the queue. You can manually request it to enshore that it is in the queue at (go to Z12 and click). Or you can render it yourself. The basic steps are covered here >

If you make a request at the information freeway then you should see it done pretty fast (few hours max).

Thanks Ben,

My tracks have now been loaded in the database, so I can download them back into JOSM. And I’m getting the hang of editing in JOSM, and I understand about uploading the edits. I’m not sure what you mean by “only some of the uploads get picked up …” Do you mean that the editing I’ve done might not be loaded into the map?

I’ve been using Mapnik, and understand it only updates on Wednesday. So presumably any edits I update on a Thursday, I have to wait until the following Wednesday before I’ll see them on the map. That or use osmarender locally.

I followed your link to informationfreeway, and I think I put in a request for re-rendering. Does this get round the “wait until next Wednesday”?


Mapnik and Osamrender arn’t related. There 2 seperate rendering projects. By “only some of the uploads get picked up” I ment by the tiles@home (osmarender) layer.

Thats correct about Mapnik. You have to wait till the next wednesday, although often It seems to be longer. I havn’t seen it update this week yet.

InformationFreeway only makes requests for the tiles@home (osmarender) layer. To get mapnik to update you need to wait till the next wednesday, then go and view the tile you want to update. It will then send a request and appear updated later on.

“You have to wait till the next wednesday, although often It seems to be longer. I havn’t seen it update this week yet.”

Where does one find out why not? The Main Page of the OSM Wiki simply says “Platform is generally stable…” for the ‘Platform Status’. Why do we have to wait until Wednesday for an update? Why isn’t Mapnik as current as the Tiles@Home stuff?

I thought I’d put in a request to InformationFreeway to re-render the bit of map that I’ve been working on. That was Thursday and my edits haven’t appeared yet. Can I find out whether this is because my method of editing/uploading didn’t work? As Mapnik hasn’t been re-rendered on its usual schedule and there are still thousands of traces pending, I assume something is seriously amiss. Does that mean that it would be better not to add more data to the queue? Does anyone know where to get status information?


kmf: Why mapnik updates in the way it does is up to the people that make the mapnik layer.

zmsc1: Are you refering to the t@h layer? Informationfreeway is t@h’s request page. Its nothing to do with mapnik. If you requested on thursday it should have updated on thursday (within a few hours). You can check by viewing the tile, and adding “_details” at the end of it. If its still old, check the links beneath and/or rerequest. Traces are uploading fine as far as I’m awair, I’m not shore what that has to do with updating t@h tiles though. There for gps data. That queue isn’t the same as the render request queue for tiles@home.

You can check the queue here>
You can check if specific tiles are in the queue here> (change x/y values)

Thanks Ben,

I understand the distinction between t@h and Mapnik, and as far as I can see, my edits haven’t been applied to either. I don’t know whether that’s because my edits were no good or the system hasn’t applied them.

I think the essence of the problem that kmf and I see as newbies is that OSM is completely opaque to us newbies. Here’s an example: Ben, who is really trying his best to be helpful advises “check if specific tiles are in the queue here> Â… amp;y=1250 (change x/y values)”. And when I follow the link, I get “OK|2208|1250|0|NOT_REQUESTED”. I can see that I needed to put my own x and y values, but I don’t know where to find out what my x and y values need to be.

The idea of OSM is great - I want to contribute. And I’ve spent two weeks reading up, submitting data, asking sensible questions in the support forum. But I haven’t so far seen any result. I don’t know whether the system is up or down. I don’t know who or where to ask. Ben has helped, but I think Ben is a contributor like me. If there’s someone guiding the development of OSM, that person or group seems to be taking a back seat. Maybe whatever technical problem is preventing the updates from happening is taking all of their time so they can’t deal with newbie questions. But that’s just my speculation because there doesn’t seem to be any actual information about the status of OSM.

I’ll shut up now; I’ve invested a fair few hours of effort, and would happily put more in, but as I’m getting no return, I’ll look elsewhere.


I agree its not beginner freindly at all. I have tried to change things such as the beginners guide to make it some what easier, but there are a lot of long winded ways of having to do some things. I don’t think its that these things havn’t been observed/critisised many times before, but rather just that there is a lack of free time for the people who have the skills to mend things to do so. It is far far far! better than it was when I joined though if that gives any idea of how bad it used to be.

Last night I requested some tiles, and nothing appeared to have happen when I checked this morning, so I rerequested and they started to change within half an hour. So there must be something up somewhere, but I have no idea where. But just requesting again and again seems to work!. I don’t think this puts any strain on the system, as it doesn’t allow multiple requests for 1 tile, so multiple requesting just enshores its there.

x and y are displayed if you right click and view the tile. There in the address I think.

If your getting no results, post a link to the area your editing (the link you add in josm or the osm map page link) and others can check it out. If your seeing no updates and you edited last week, then you must be doing something wrong, becuase I am seeing edits I made last night completly updated now.

Usually the changes made to the database are passed to Mapnik once every week. Unfortunately part of this process (the creation of a database dump file) failed this week and therefore Mapnik won’t show the changes from last week. The source of the problem has been fixed and therefore you can expect the Mapnik to reflect recent changes from Wednesday this week.

T@H is in place to cope with the weekly delay of the main map. Unfortunately there are some issues at hand with t@h as well. Ben is correct (unfortunately) when he advises you to be patient and request your areas (once) every day when they don’t reflect your recent changes properly.

I feel your frustration and you are not the only one feeling this way, but: As OSM is a (very young) community project. It doesn’t really have any people ‘in charge’ or ‘responsible’ but is dependent on community effort instead. This has advantages (large userbase) and disadvantages (no money to buy servers, limited development time in some key areas). As the userbase grows exponentially the development of userfriendly tools and robust server software is trying to keep up.

Recently (a few weeks ago) OSM migrated to a new webinterface which caused some (unexpected) problems. These problems are slowly being squashed resulting in ever better performance and functionality, but they require some patience.

Well I hope that you take a deep breath, a pint of beer or whatever and are able to find the patience to become a bit more familiar with the project. I’m sure it is worth it…don’t give up yet.

If you have urgent questions I suggest you join the IRC channel and just ask. I’m sure lot’s of people are willing to help you out there. If you have suggestions for improving OSM or just want to see what is going on then the mailing lists (dev and talk) are resourceful. Of course you can ask your questions here, and if you don’t understand the answer, rephrase the question.

Thanks Lambertus, I’ve taken your advice.

Now another discovery hurts my brain. I’ve uploaded several traces, and as you know used JOSM to turn them into fragments of map, but I don’t yet see any of my edits in Mapnik, and only 1 after requesting re-render in informationfreeway. But I just looked for the first time in the Potlatch editor and I can see both traces and ways that I have made! These are traces that I thought were still pending. I sort of supposed that potlatch, informationfreeway and mapnik were all based on the same data. I’m obviously missing something important: does “pending” mean something other that “we’ve got the file you uploaded and will apply it to the database at some later time”?

Once you have made changes, osmarender can be updated instantly as the changes are made the second you upload, so a request will see the tiles updated within a few hours. Mapnik however uses a weekly export from OSM (planet dump) to make its maps from, wich sometimes (like last week) doesn’t successfully export. So mapnik isn’t upto date, as is clear at the moment.

Informationfreeway is a site for use with the osmarender layer. It has nothign to do with the mapnik layer. Mapnik requests are made automatically when viewing tiles at the main OSM page, but they update from an outdated source.

Uploading traces has nothing to do with making edits. Pending means what you said. It’s sitting in a queue and about to be uploaded. It should take about 1/2 an hour, but sometimes its quicker, sometimes it gets jammed and locks and could take days, as has happened recently.

I would suggest posting a link to the area you are talking about, becuase if you have re-requested renders from informationfreeway and t@h still doesn’t show what you think it should be, then it sounds like the data may not be correct.