Is it possible to change path colors in/for eTrex 30x/32x?

When using maps created with mkgmap some paths show up white in the GPS (30x and 32x). When on an unmapped white background they become effectively invisible. By hovering with the pointer where I know they are, information about the path is shown, but I can not see the path itself.

Checking back on OSM I believe those that have highway=path are the ones that become invisible unless on a differently coloured background. They are called line in the GPS.

As a counter example, those marked highway=footway are visible as dashed dark lines. They are called trail in the GPS.

The generic paths are often used where the usage is shared between pedestrians and bicycles. The mapper probably chose the generic name as neither pedestrians (highway=footway) nor bicycles (highway=cycleway) were more the main audience than the other.

(Using the same map in an older Legend HCx GPS both are drawn in a brown colour. In this particular aspect, the old GPS is better than the new.)

Is there anything I can do about this? I have looked for some settings in the GPS, but haven’t found anything applicable. The mkgmap has a “style” concept, but that appears to be on a higher level. Is this something that could be used and if so, how? Or is there some other way to improve the rendering in my GPSes?

It would help to know which map you use on your devices, where did you get it from? Most map providers combine the map with a TYP file that is responsible for the displayed lines and areas. The normal approach is to modify the TYP file that is combined with the map. You may either ask the map provider to do that or you can try to modify it by yourself and replace tge embedded TYP file with your version. Tools exist for these tasks, but I don’t know them of my head.

Sorry for the slow follow up here. (I expected to get an e-mail notifying me when there was a reply. Apparently I have to adjust some settings.)

I download my maps from Geofabrik. I only see map files (.osm.pbf) files there, not any “TYP file”. I run splitter and mkgmap on the downloaded file. I have a long list of options to mkgmap found by googling and experimentation. Is this where I should add a TYP file? The output of mkgmap --help=options is long, and in one place mentions a TYP file, but I don’t see any option for adding one. And since I don’t, can I somehow see what mkgmap uses as a default?

The typ file should be given as last input file, no option is needed. See also
The mkgmap distribution comes with an example typ file that renders similar to the mapnik style used on
Various other styles and types are available.

Thanks for those additional hints. I’ll follow the pointers to read up on how to create a TYP file, and try to make one that solves my problem. Thanks a lot!