Installation of osm maps into mapsource, first worked second fails

Hi , I am a hard working newcomer with gps 60csx and it pays off. :slight_smile:
I was able to transfer tiles into mapsource and it worked fine, then I asked for another set of tiles from OSM, which I transferred as well to mapsource but now mapsource fails and will not work any longer. :frowning:
Above “Karten Details” in the mapsource screen I get something like “nicht freigestellt”
I have now deinstalled several times mapsource according a detailed instruction from a surprisingly fast answer from garmin customer service but if I install only the first OSM maps it works if intall the second too it fails.
I am at the stage where I am lost.
The link I got to download the second set is as follows.
http://planetosm.oxilion.nl/~lambertus/garmin/routable/09-07-2009/afbbcd7dfda16b63363c77d9420f2cbb

I would be happy if someone could help me

Just a suggestion to save re-installing MapSource.

Keep a “last good working” copy of your .IMG and .TDB files in another folder.

(My basemap images are called 63240000.img and 63240000.tdb. The basemap .imgs are fairly small around 100k. The map .imgs you downloaded will be a megabyte or larger.)

That way you’ll be able to overwrite the new non-working files with good old ones. When you installed your first OSM map, the installer created registry entries for it. Any subsequent OSM maps should either add registry entries or overwrite the existing ones. If MapSource doesn’t find what it expects it will choke.

Finally, do you have any idea what “nicht freigestellt” translates to in English? My gymnasiumdeutch isn’t up to a MapSource translation.

nicht freigestellt could be not released or not unlocked or something similar I guess.
Thanks for your hint

Considering that OSM maps are not locked, is it possible that you have some locked maps, Garmin products like City Nav NT in the US that are having problems? Perhaps share the same *.img name?

The OSM maps you downloaded certainly do not need unlocking, but perhaps you’ve encountered a problem where the maps from my service interfere with a commercial map. But I never heard about such a situation before.

How do you keep the OSM .img numbers separate from the Garmin Locked numbers, or, for that matter, from the .img numbers of other third party mapmakers?

Nope, not intentionally. Is there a list of occupied numbers?

all maps I got in Mapsource are
no card
osm world rotable

I had initially a map installed from South tirol
http://www.maptk.dnsalias.com/Maps/Südtirol%202.00%20Setup.exe
which i currently have not installed

I do not find a list of occupied numbers,
I am not a master of the Regedit as I always tried not to touch it yet, and I did not find any .TBD files in my system

map trip and waypoibrmgr v5 is there as well its the one which came with the system

Ok, so you currently have only one map installed: the osm world routable. You should definately not get a question about unlocking maps.

But if you still do then: Please run the setup of that map again and don’t change any setup option. Just let it install in the default directory. Do you still have the unlocking error when the installer has finished?

http://www.keenpeople.com/ maintains a list referenced on the cgpsmapper site, and Garmin might be induced to share their rules. Everything in my City Nav North America NT folder starts with 0024???.

Ah, they seem to maintain some list indeed: http://www.keenpeople.com/index.php?option=com_maplist&Itemid=78

But I have to register before being able to have a look at it. Maybe I’ll do that one day.

I GOT IT.

solution was: I requsted all the tiles I had done before in two lots in one now, had deinstalled the images from the previous attempts and executed the combined request and it worked fine.

This solved my current problem but I wonder what will happen if I need another tile and try to add it?.

thanks to the contributors

Ah yes, you cannot install two different maps from my service on the same pc at the moment. The overview map is overwritten so you’ll only see the last installed map, but it shouldn’t complain about unlocking or other stuff otherwise.

If you want to use this service to update an already installed map then you’ll have to request all the tiles you had installed before as well. There is a solution for this but then you’ll have to get to work with mkgmap or other Garmin tools yourself. I plan to make multiple maps installed in parallel possible in the future.

Anyway, great to hear it’s solved.