incorrect street name locations

Dear Sirs,
kindly note that we have a GPS Tracking system in Beirut, Lebanon with OSM nominatim installed but our clients complaining that many locations show incorrect street names, please we are asking how can we update these locations with correct street names and then update the package to our server?

we already contacted our system providers and they replied with:

Mary: It should be fixed on the Nominatim itself (in its database). Only they can fix it.
Mary: But they should be changed not on your server, on Nominatim side, in their database firstly.

Andrew: you need to set up the automatic update of the nominatim, SO, once it’s fixed in the database of your Nominatim, your server will update the information

Please we need to know how can we update these locations, and we appreciate your help
Thanks a lot and have a nice day.

Best Regards.
Mahmoud Zeitoun.

Firstly, any correction must not be based on a copyrighted map, nor can you use Google Streetview to look a the street signs.

The only safe way of getting the right names is to actually go to the place and look at the street name signs or ask local people. It is possible to use some other maps, but they need to be under copyright licences that have been approved by OSM. Most maps do not have such approval. In general, the people who produce those other maps will need to communicate directly with the OSM people in order to get that approval.

Once you have the correct name for the road, you can use any of the OSM editing tools to correct it. The simplest way, although not particularly scalable is to go to find the road, Click the “?” button, then click on or near the road, and select the specific road, or part of it, from the list on the left of the screen.

Next select Edit, and type in the correct name, Then select Save and describe what you have done, and how you found the correct name. It is perfectly reasonable to use the native language for this description.

Note that the general policy is that the name should reflect what appears on street signs and is used locally. If that is in Lebanese and Arabic script, that is what you should use. There are mixed views on how to handle places where names are given in both Roman and local alphabets, and you should use local conventions as to whether you just use the native language version or you use both in and the Romanised one. In such dual naming cases, you should add name:XX where XX is the ISO language code, for each language version. Romanised versions are normally coded as name:en, even if they are simple transliterations, rather than translations.

For more serious editing, I would suggest using the JOSM editor.

Note it is not acceptable to simply overwrite names without looking at what was there before. In particular, so called, official source of names can be wrong, and the name actually used takes precedence.

hadw did a good job describing how the data can be fixed in the central OSM database.
After it is updated there, you still have to update your copy of the database, i.e. the database that is feeding your Nominatim server.
That update process is described on the wiki.

Did you check to see whether the names of the streets are correct ? Perhaps your data is already out-of-date, perhaps there is a problem with the implementation of Nominatim to display addresses for your area. Did you try to look up the address in ?

Can you provide some examples of incorrect addresses (links to ?

Hi everyone

I’m asking this on behalf of Technovision, as I was the one installing and configuring the Nominatim. For configuring updates I’ve followed this guide:

We are using full globe data, and at first I’ve configured updates from daily extracts and my settings looked like this:

// Base URL of replication service
@define('CONST_Replication_Url', '');

// Maximum size in MB of data to download per batch
@define('CONST_Replication_Max_Diff_size', '120');
// How long until the service publishes the next diff
// (relative to the age of data in the diff).
@define('CONST_Replication_Update_Interval', '86400');
// How long to sleep when no update could be found
@define('CONST_Replication_Recheck_Interval', '900');

And I’ve configured cron to run “./update.php --import-osmosis” once a week. But after looking at the logs recently, I’ve noticed in the logs this:

2017-10-29 10:03:08 Completed index step for 2017-07-18 23:58:52 in 286.2 minutes
2017-10-29 10:03:08 Completed all for 2017-07-18 23:58:52 in 483.12 minutes

Does that mean the updates weren’t running successfully? Right now I’ve changed the settings to minute diffs:

// Base URL of replication service
@define('CONST_Replication_Url', '');

// Maximum size in MB of data to download per batch
@define('CONST_Replication_Max_Diff_size', '30');
// How long until the service publishes the next diff
// (relative to the age of data in the diff).
@define('CONST_Replication_Update_Interval', '75');
// How long to sleep when no update could be found
@define('CONST_Replication_Recheck_Interval', '60');

And executed “update.php --import-osmosis-all”

Now it’s running and still giving me this:
“2017-10-30 13:37:26 Completed all for 2017-07-19 03:08:01 in 22.22 minutes”

Can you please tell if there’s something wrong with those settings, and how can I fully synchronize our copy of database to the latest version and keep it up to date correctly?

Actually, I’ve already asked this question before:

But didn’t get reply. I don’t thin that documentation cover all this for people like me, who don’t know very much about inner workings for the nominatim database.

I’ve tried to configure update from daily diffs again (I believe that minutely diffs for the whole globe is not optimal) and run it with --import-osmosis-all option

Now it gives me:

2017-10-31 05:55:29 Completed all for 2017-07-21 23:59:01 in 387.45 minutes
Currently at sequence 1774 (21/07/2017 23:59:01) - t indexed

Does that mean that database is slowly being updated and will continue to update until current date?

I’ve never updated a nominatim database, but from the settings you posted, you’re probably running into this:

Your database was more than 10 days behind and still is 10 days behind, you’ll probably have a lot more than 30 MB of database-replication-files to catch up to.
So if you run the update command multiple times in a row or increase that limit, it should continue to catch up.

Generally speaking, if you do not intend to update the database more than once a day, then use the daily diffs. That will reduce the load on both your and the OSM servers (because e.g. an object created and deleted again 5 minutes later will not be in the daily diffs, but it will be in the minutely diffs, so you have to download and process it).

Sorry, that’s just plain wrong. See:

Sorry, wrong phrasing on my part

But, if I run

update.php --import-osmosis-all

Can I just leave it running and the database will be slowly updated until the latest version in the batches of 30 mb, considering the settings above?