Incomplete gmapsupp.img from

As suggested in “Question and Answers” forum, I repeat my question here.

I downloaded a self-generated map from (via the link I received in an e-mail).

The windows installer installed the complete map I requested in Basecamp : no missing tiles.
The gmapsupp.img I copied to my Etrex misses several tiles (at least, they are not rendered on the Etrex).

How to go ahead to have this issue resolved (I already tried it two times, with the same result) ?

Note : the link to the map in question is

Do you have other maps in your GPS? There could be a conflict, especially if you have other OSM map.

Maybe you can see the details if you zoom in more?
Only if I zoom out I see those gaps too, but they disappear when zooming in.

Thanks for the suggestions.

Zoom factor does not have an influence : holes are “visible” both zoomed in and zoomed out. Also, searching for cities in the holes does not give any results : from the outside it looks as if the holes really are not there. I would check out gmapsupp.img directly, but do not know how.

Conflict with other maps would be surprising : there are other maps present, but only one map is enabled.
I did notice the layout of the tiles in the area in question recently changed. The disabled maps still have the previous tile layout.
Is it possible to have conflicts with disabled maps ?

Yes. Each tile has unique number. If you have 2 tiles with the same number, GPS will assume that this is the same map and will ignore second copy. Regardless of enable/disable state. You could try to temporary remove other maps, for example rename file extension to something other than “img”.

Yes there could be conflicts, you can check it with javawa device manager:

It has a report function so you can share it here for further analysis.

Problem solved !

As indicated in the answers above, the problem is due to conflicts with other maps. I made a quick check changing the filename extensions of the disabled maps, restarted the Etrex and the problem was gone.

I was aware that conflicts can arise when different maps cover the same area. I am surprised to learn that these conflicts also arise when maps are disabled.

Thanks for the support !