In Basecamp the base map superposes the normal map

I did download some OSM Maps “gmapsupp.img”, renamed them to be able to store more than one map on my device and stored them on the micro memory card of my oregon 450.
They are shown OK in the oregon 450 itself, but not if I consider the same map from the same micro memory card inside the oregon, but with the program “basecamp” on my computer. Here it is obvious, that parts of the “base map”, as example autoroutes, are shown also on the normal map itself. So I see the autoroute on the map twice, once simplified as in the base map and once as it should be in the normal map. If I find a possibilitie to attach images, I attach to this thread screenshots of two examples showing the same area. I combined a screenshot of the normal view together with the screenshot of the view which I get when I press Ctrl G (which means in basecamp “nur Basiskarte”) into one image.
A1 shows the area reasonable, only a black line is not correct. A2 is unreasonable, a part of the village is under water, obviously the coast line has been copied from the coastline in the base map and the Autoroute also is at a place where there is in reality no autoroute.
I have basecamp 3.2.2 in German. This happens on two computers, one with Windows Vista and the other with Windows 7 /64
Any advice what to do to be able to see the images undisturbed also with basecamp?

What happens if you download the BaseCamp/MapSource installer rather than the gmapsupp.img? Does the problem still exist?

Yes, this is a known mkgmap issue. It seems the gmapsupp img’s become transparent when viewed in Basecamp (if they are read from SD card or GPS unit). See this screenshot: and read (in Dutch, so use with google translate) this thread or this page:

There is a workaround and that involves replacing the Basecamp “Global Application Basemap v2.gmap” (which does not contain anything interesting at all) by an empty one. This map is located in C:\Program Files\Garmin\BaseCamp (or another folder is also possible).

The maps from, which i mainly use, don’t offer a file for the mapsource installer. But they offer a file for a NSIS installer and I made a test with that: I downloaded two lengthy files, one “” to have after unzipping a gmapsupp.img which can be loaded direct into the garmin handheld. The other “”, which contains a lot of files and to install, needs a lengthy procedure.
The result of the first installation is a gmapsupp.img in the folder “Garmin” from my handheld, which I can display in the handheld oregon, here without the overlay problem. which I can display also with basecamp, but here with the overlay problem. And this displays are possible also from another computer, when I connect the handheld to the other computer.
The installation from “” results in a new folder on my handheld parallel to the garmin folder, which can be displayed with basemap now without the overlay problem. But this installation has a lot of disadvantages: the installation procedure is complicated. It must be done on every computer on which I want to look with basecamp to the map. And to see the maps also on my handheld, I must copy the *.img files to the garmin folder of the handheld, which results now in two maps to be seen with basecamp , one with the overlay problem, the other without it. And, on the handheld, the map is splitted into several maps which must be deactivated/activated separately. So the only reasonable procedure would be the following: to download both of this lengthy installer files, to install the gmapsupp.img from the first installation on the handheld and to install the “nsis” installation on the desktop computer and the Laptop and to live with the display of two maps of the same area in basecamp.
I would be happy with every recommendation of a better solution.

Have you tried to replace the basemap?

Our entrances did cross each other. Yes I tried it with success. Tankyou for this advice. Only one map (of Russia) did show the problem further, but I can live with this. This map required gmapbmap.img to be in the same folder, which was not the case for other maps.

That is possible, because I created this basemap for myself (only for Europe). Maybe you can try Javawa’s which is larger, see for the link, but his map wasn’t routable on my computer. I dont know what you mean with: This map required gmapbmap.img to be in the same folder?

On my handheld I have the folder K:/Garmin (the handheld itself) and J:/Garmin (the mikro Card inside the handheld). First I had the file gmapbmap.img only in K:/Garmin and the gmapsupp_Russland.img in J:\Garmin. To try to open the russland map with basecamp resulted in an error message. As soon as I copied the gmapbmap.img also to J:/Garmin, I could open the map.
If I have an USB Stick on my computer with the folder garmin in it and the russland map, this map opens also only if gmapbmap.img is in this folder.
In the meantime I downloaded a newer map from Germany, but now in using this map the faulty overlay is back. I believe I have to accept that some maps are showing this effect (also with your workaround) and others don’t. I can’t discover any reasonable difference in this maps who could explain the difference in behaviour. Probably this are not effects of my computer but effects in the producing (rendering?) of the maps.

I have not noticed this effect, maybe you can check with gmaptool if the MS flag in the header is set to 0 or is still 1. If this is set to zero, you can view the img in Basecamp. Maybe you can also see it in combination with gmapbmap?

Another tool to reset the Mapsource flag is with imgmod from Javawa, see the link in my message above.

Edit: just checked out some maps of raumbezug (gmapsupp from Hamburg, Belgium) and noticed they set the Ms flag to 0 and it shows fine in Basecamp.

If you can extract the files from the NSIS installer, and they include IMG files, an Overlay Map IMG, and a TDB file. You can use MapSetToolKit to INSTALL (button on bottom right near center) the maps in your MapSource/BaseCamp.
Note that MSTK only performs a simple registry edit to do this, and it will work with mkgmap compiled maps. The START button requires cgpsmapper and only works with cgpsmapper compiled maps.

Thanks to all of you. But I am a beginner in using OSM Maps and dont know until now all the programs around the production of maps. It needs some time to understgand all this. So I will stay for a while with the situation as of now. At least the maps all work well in the handheld itself.

The bug of Basecamps Base map superposes the OSM map has just been traced and solved by developer Steve from mkgmap, so sooner or later the results will be visible in all the OSM maps that are produced with mkgmap.