How to use Routing with and OSM map on a Garmin?

I own an mapping device (GPSMap 62S) for two days only.
I’ve unzipped and copied the complete German map…one_Garmin_Map

to the Garmin folder of my SD card within my device.
The maps show just fine but when I press the Find / Addresses buttons
it asks “In what state or province is the address?”
Regardless what I enter it doesn’t find it.

What am I missing and how to use Routing with that map on my Garmin device?

Many thanks for your help,

You seem to be confusing finding an address with routing.

See the sticky thread at the top of this forum:
Quoting from that:

So yes, finding an address on the Garmin doesn’t work properly.
But routing should work. ie if you scroll around the map, you can pick a point and choose “go to”. Then the Garmin should create a route to that point, following the roads etc (depending on the routing settings on the device). Or you can go to find, then choose cities (or shops or hotels etc), then pick a place and “go to”. Then you will get a route to that place.

I have the same problem on my nuvi 250, routing works fine using “favorites of recent locations” but entering a new address doesn’t work.

You can try this:

  1. Find the needed town via “Main Menu - Find - Cities”.
  2. Click the town and then search via “Menu - Find Near Here” the needed street.
  3. Choose “Go To”.

Some Garmin units need maps compiled with the mkgmap option --road-name-pois to find streets, e. g. the Oregon series.


This works fine for finding the City, but options 2 and 3 don’t work on my (updated) nuvi 250.
I noticed that the Cities are followed by “,ABC” what means that the description of the country isn’t found by mkgmap. It also would explain why the list of states is empty!

What means “doesn’t work”?

Are no streets listed? Or is at your GPS unit no option “Find Near Here”?

If there are no streets listed you need another map which is compiled with the option --road-name-pois. Then you can find all streetnames in “All Pois” or “Geographic Points”.



I tried it again and now found the streets under POIS. I got confused translating the information to my dutch nuvi.

Thanks, now it works.