How to revert a vandalised area

We have a problem in the map here

A part of the data was deleted, probabely with JOSM, so how to fix this

thank you

The data was deleted in this changeset:

which I’ve just reverted in this one:

There were no reported errors and no conflicts, so everything should be back as it was, but I’d suggest that you check for things that you know should be there to make sure that nothing has been lost. One thing to be aware of - because an osm-carto style update has just been rolled out, the rendering of tiles may take a little while to catch up. For example tiles at this level:

now render, but zoom out and you’ll still see gaps. These tiles will get rendered shortly, though.

Thank you SomeoneElse,

So how can i revert a changset if it happends another time ?

JOSM Reverter plugin is very easy to use, just run it with the changeset id.
There are some general revert documentation in
and how to response to vandalism

Yes - sorry for not saying “how” and just doing it, but in this case it was (a) quite an old changeset (the older the changeset the more likely are conflicts) and (b) quite extensive (again, more chance of conflicts).

Here’s what I did:

First I went to your link and zoomed in between a couple of non-deleted features. I then edited with Potlatch 1 (by selected “Potlatch 2” from the edit menu and deleting the “2” from the URL) and used Potlatch 1’s “undelete” feature to find something that had been deleted (there were of course lots) and checking that in each case it was the same changeset.

I then looked at several items in the changeset to make sure that they hadn’t already been undeleted or reverted (just by clicking through the OSM “browse” links), and checked that the relations hadn’t been subsequently edited (since if so they would need patching up afterwards).

I mentioned on #osm on IRC that I was reverting this changeset (in case anyone else saw your message and tried to do the same at the same time)

Then I used JOSM with the “revert” plugin and tried to revert the changeset (with a separate account so that it would not get confused among my “normal” edits). The first attempt failed during the revert before the re-upload, so I went through JOSM’s stacktrace (which is handily presented in an on-screen window) to see what the problem was. In this instance it was just an HTTP 500 from the API (unusual but not unheard of when doing a large number of API calls) so was able to just try again, but I did check that I was running the latest released JOSM and updated plugins before doing so.

The second time the revert went OK, and I was able to upload OK. I briefly explained what had happened in the new changeset comment. I also checked that the uploaded data did look correct (or at least, that there was now some data again where there had previously been none)

Had JOSM presented any conflicts at this stage I’d have had to try and resolve them (by looking at the scale of the conflicts; if large, JOSM’s revert may not be the best tool to use). JOSM “warnings” and “errors” at the upload stage I would ignore since I was not planning to change any tags to be “correct”; just restore the data to how it was before deletion.

I sent the user a message and also added a comment to the changeset discussion on the original changeset (I had to do both because the date of the original changeset predates changeset discussions being turned on, so the user would not get the message from that).

The user appears to be Korean; I don’t write Korean and I’ve no idea how good Google’s machine translation of English to Korean is (I know that it’s English/Japanese is ropy) so I just used English in the messages. The message sent “assumed good faith” - it may be vandalism, but it could also just as easily be someone getting completely confused and just deleting everything, or thinking that they are editing a personal map not a public one.

If you want to try reverting a changeset using JOSM and haven’t done so before I’d suggest getting familiar with the process using the “dev” server first before trying on the live one (you’ll need to create a separate login there, but once you do you can create and revert test data to your heart’s content). Obviously when using JOSM you’ll have to remember to switch it between the live and dev servers when you want to test things!