How do I turn off PM functionality in Discourse?

Apparently, Discourse supports private messages. No surprise in that, I guess, and it was something that I think the old forum supported (though I rarely got messages there via that route).

However, yet another PM mechanism is something that I don’t need - it’d be great if users attempting to do this could instead be directed to the existing OSM private message mechanism instead.

Preferences → Notifications → Uncheck Allow other users to send me personal messages

I think this may be tricky, IIRC, we’re not storing the display name, which would be required to generate the link to send private messages.


Thanks - another reason to move to UID-based APIs, I guess (and yes, I know that that is far from straightforward and someone would actually need to volunteer to do that)?

Even with that link, it took me a while to find. On desktop, the route is:

Click on the letter corresponding to the first letter of your user name at the top-right of the screen. The tooltip is the display name.

A menu appears. It has 4 unlabelled tabs. The icons for the tabs offer no clues as to what they do, Select the right-most tab.The tooltip is “Preferences”.

Another menu appears, and this one actually has words on it. Select “Preferences”.

We’re now onto the 3rd different tab paradigm in as many screens - now the tab selection is via vertical words in the left-hand column. On other pages these words are filters, here they act as tabs. Select the word “notifications”. The URL for me is - I’ve no idea whether that can be directly linked**.

Scroll down. “Allow other users to send me personal messages” is a tickbox. Untick it and click “save changes”.

** Edit: yes, it seems that it can be.

Oh, I thought navigating to the preferences was a bit more widely known already. I’m posting a few screenshots for clarification:

Step 1: Go to preferences (click on your avatar, then click on the 4th tab in the popup, click on Preferences, as highlighted in yellow):


Step 2: Click on Notifications in the menu on the left:

Step 3: Uncheck this one and save changes:



What an epic fail: Discourse would only tell you that a receiver won’t accept personal messages after you’ve typed your message and hit the “Send message” button. :person_facepalming:

“Sorry, {{username}} is not accepting messages at the moment.”


You can report it upstream, it seems like a clear improvement to apply:

Please, let me know if you would like support reporting this.


For completeness, there may also be a couple of other foibles regarding mails to groups, where some of the groups’ members doesn’t accept PMs - but unfortunately I don’'t have time to pin those down at the moment.