highway=path missing on Garmin maps?

Hi all,

I am using OSM Composer with (AFAK) default settings who in turn uses mkgmap to create maps for my Garmin Vista Hcx. It works well and creates great and up-to-date maps, but now I have discovered one problem:

If ways are marked as highway=path and foot=designated they are not transported to the map.

I don’t quite know the result of the highway=path/foot=designated vs. highway=footway discussion, but in any case both versions exist in OSM data and should imho yield the same results. However they don’t on Garmin maps created by OSM Composer.

Does anyone know what I need to configure to achieve that. There are a lot of settings that can be accessed by the buttons at the top part of the OSM Composer window, but I don’t know what achieves the desired result. Also there are the main settings where you can define external settings files.

So any help to guide me through the settings I need to tweak would be greatly appreciated!


Ok, I found a solution: updating to mkgmap853 from 590 did the trick. Since I already started, now I am looking into getting shelters and chalets on my Garmin :-).