Help Please

Several months ago I tried to make an addition to a NSW Australia map.
Summer Hill Road was shown not to go thru,but thru local knowledge I know it does.
I must have done something wrong in my change ,as although it show correctly on OSM, if you try to plot a route on Locus starting on Summer Hill Road and turning left on to Glendonbrook Brook Road, it acts as if you can’t proceed and reroutes you to do a loop and come back down from the north east.
What have I done wrong
I tried to post a screen shot of the area but couldn’t work out how to do it
53681963 is the change set# if that helps
As you can see I’ve got no idea what I’m doing
Thanks Paul

Seems fine to me.
It is likely that the Locus app has not updated the map data since the changes were made, particularly the routing component if separate.

G’Day Nev, thanks for the quick reply , I think the Locus app has the updated map but I will check it out again
I wish you lived closer, I’ve got no idea of some of the instructions on how to do various operations .(even how to post a screen shot)
Thanks again Paul

Hi Paul, I’ll have a closer look at the tags tomorrow unless others beat me to it. I can’t check Locus Maps as I only have an iphone.

Thanks Nev

Hi Paul
I think the map data is correct.
I downloaded the area from as ‘Generic Routable’ and opened in Bascamp and then routed from Horns Crossing Road to the western part of Glendonbrook Road and it did route me northeast through Gresford instead of taking the shorter route using Summer Hill Road.
I checked Basecamp > Preferences > Routing and it had the ‘shortest route’ selected but also had ‘Road Type Avoidances’ > ‘Unpaved Roads’ checked.
As Summer Hill Road is tagged as unpaved or gravel the road was avoided and the longer route preferred. The route chosen appears to be asphalt on the satellite imagery on the few bits I checked. If there are no surface tags I think the routing assumes it is paved.
When I unchecked the ‘avoid unpaved roads’, Basecamp routed me along Summer Hill Road instead.
There are likely similar preferences in Locus Maps causing the same problem.

Note that routing is handled by a different data source than the map you see. They both derive from OSM, but may be snapshots of the data from different points in time.

Locus has 3 online routing options, and the router you choose would need to have the updated data for it to route correctly, regardless of what you see on the screen. Depends on the routing service. Locus also has one offline routing option, and you’d need to manually update the routing data files if you’re taking that path.

Routing cannot be done directly from a map as displayed. It needs “routing data”. Sometimes the two are packed into the same bundle, as in the Garmin example.

Thanks Nevw and Viajero, for your replys