Help. New user having trouble deleting a 65km section of road.

Being a new user I really don’t like claiming things are broken prior to getting some advice. I have created the town of Yirrkala in the Northern Territory which worked great. New streets, new POIs. If I made a mistake I could go back and fix it instantly. Fantastic.

The problem I am having is that I am trying to delete a 65km stretch of road heading out from Nhulunbuy/Yirrkala and replace it with my, albeit exactly the same, but more detailed and MUCH longer highway. Every time I click Shift-Delete in potlatch to delete the road it pops back up. Again and again. I log out and log back in, and again. I must have tried this around 50 times by now. Am I pushing the limits of the system by deleting such a long road? Do I need authorisation to delete such a long road or do I even need to do it point at a time.

Please someone help. It feels like I am fighting against one of those stupid bots which constantly change the things you are editing.


  1. Welcome to OSM :slight_smile:
    Thank you for asking here instead of messing things up.

  2. Please always post a permalink, an ID or a direct link to the node/way/relation.
    This will help everybody to take a closer look to the item you’re having trouble with.
    Permalink: Lower right corner on
    ID: Show in almost every editor. Or enable the datalayer on (blue “+” in upper right corner). This will also give you access the link to node/way/relation.

  3. Potlatch (or is it the OSM-Database?) sometimes is a bit lazy. Normaly after restarting Potlatch the data of the area is reloaded and you should get a proper result.