Garmin Nuvi 215W - Problems loading map files

Good Evening,

This is my first post and am looking for some help please.
Just purchased a Garmin Nuvi 215W, which only has UK & NI maps on it.
I am trying to load a map of Cyprus onto a new SD card and am having problems.
I saw on OpenSteet Map a free download for Cyprus in gpssupp.img format. I made a file on the card as ;garmin; and load the map on that file. Although my nuvi 215W recognises the entry when searching tools/settings/map/map info as

'openstreetmap for garmin by raumbezurg GbR
[1] OSM Map of Cyprus

and searching results in city search/town/search/street search but up pops ‘no match found’’
Also , I cannot see any actual maps etc.
What am I doing wrong or is there more to this misterial subject than meets the eye for an old 76 year old clueless fool.

Could do with some help and guidance.

Warmest Regards to everyone.


Always difficult to completely answers questions, so here are a few clues which may help.

File structure of Garmin and where to place a map:

Maps can be constructed (or downloaded if you want standard areas) here:

if you have Mapsource installed on your computer, an easy way is to download the files for Mapsource, install the downloaded map on your computer (make sure it is in the folder where Mapsource stores its maps) and upload from Mapsource to the Nüvi.

Hope this helps, else post a reply, Hugo

Hi Hugo,

Many thanks for your kind response and help.
Looked at your suggested sites which were very helpful.
However, I decided to persue to MapSource route and after downloading etc, found a map of Cyprus
from the OSM World Routable map. Selected Cyprus, used the mapping tool to surround my choice. It turned pink
and I named the map. I then transferred this to my SD card and it showed up on my Garmin 215W, which I ticked to use.

On selecting where to/address/select city/nicosia/street the result was an error ‘No Match found’

Any ideas

Warmest Regards



I forgot to say that the file I transferred from MapSouce is in format GPSSUPP and NOT GPSSUPP.IMG. The latter is not recognised. Its almost as if I am nearly there but one little file or something is missing.


I have some trouble understanding what’s going on, so I’ll approach this from the other side:

Make sure there is a directory ‘\garmin’ on the removable disk that is your GPS.
(1) Unpack the file that you’ve downloaded from the website.
(2) Place the unpacked gmapsupp.img in the ‘\garmin’ directory on your GPS.
(I believe the nuvi allows you to rename the file to aything, so you could try cyprus.img if there is already a gmapsupp.img in the ‘\garmin’ directory.)
(3) Reboot the GPS device and select the ‘OSM world routable’ map.

Note: if the unpacked file in (2) is named gmapsupp (without .img) or the file in (1) is shown without the .zip extension then your operating system (Windows) does not show known filename extensions. You should then copy the file to the GPS and also not see the .img behind the filename, otherwise you’ve accidentally renamed it to gmapsupp.img.img

Hope this helps…

Hi Hugo & Grant,

Hope you are both well. Have had a bit of success but still not right yet.
Download an OSM Routable map in format. Unzipped and loaded onto SD card. When I open the Nuvi 215W I could see that the SD card was recognised by seeing phrase Family Name [1] OSM World Routable underneath the CN Europe NT 2010.10 [1] UK & Ireland.

The Country of Cyprus does not show up when changing Countries, however I know the maps are in there because selecting Cities and spelling out for example Nicosia, I see a detailed map of that City. All Cityies/Towns are shown as for example Nicosia ABC. If I take out the SD card then detail outside UK & Ireland is very scant and probably taken from the built in World Map.

Any ideas why the Country is not listed.

Look forward to any suggestions. Not so godd on this subject but I am a mean motorcycle mechanic and have a 1964 Triumph T100 classic bike I fully rebuilt.

Warmest Regards


The country is not listed because the maps from are not created with country codes. It seems that everything is working now as expected. Congratulations!

Hi Lambertus,

Thank you for you constructive advice on my partial success in getting an openstreet map onto my Garmin Nuvi 215.
Although as you say no country codes were created from this routable map, is there a way that I can modify this map to show up the country when searching for countries on the Nuvi.

Seems a shame that the project is missing this info as there would seem to be no way of actually choosing a route.
The only way I know that the maps are there is by searching for a city then viewing the map. You cannot actually choose the new country for the newly inserted SD card.
Any suggestions.

Warmest Regards

As the map build process is completely dynamic, it is difficult to determine the country code of each tile and also many tiles span multiple countries. I don’t have a solution currently to add a country code to each tile.

Thanks fo that Lambertus,

So am I right in thinking that although the downloaded map of Cyprus is on the SD card, whilst on holiday in Cyprus I am unable to select ‘where to’ to be able to choose a route from one location to another.



No, I think it should be perfectly (well I hope so) able to route from A to B. I’m not aware that you need to enter a country code on a Garmin, but I don’t have a Nuvi.

Can you search for a city first and then search for the street name? That should work around the Country/State problem…

Hi Lambertus,
Sorry for delay in responding, been away for a few days.

OK here’s the situation on the Nuvi. Have done a test by downloading Openstreetmap: Great Britain and unticking the built-in
CN Europe NT 2010.30 UK & Ireland.
The GNuvi sees the map OK but cannot route. This is what you get :

  1. Where to
  2. Address
  3. Select City - spell city/search all
  4. Spell City type in name
  5. Select City Enter House No Enter street Select street

So that’s it. The only way I know the that the map on the SD card is there is to select Where to and go to Cities then spell the name of the city required.

All of this means that the Openstreetmaps are not routable from A to B but just act as a nice map to view. I can buy a map from my local shop and do that.
unless I am missing a very vital piece of downloadable info.

Your comments would be most welcomed.


Try leaving the city field empty when searching, but you MUST enter a house number. This works for me in Mapsource.

I really wonder who recommended Garmin Nuvi 215W to him. I am from Portugal and had purchased it last year. Right from the beginning I had problems with it. The most annoying thing is that it is extremely difficult to load new maps. I tried loading the map of Portugal on a number of occasions but was not successful. Finally I gave up hope.