French accents

Please apologize if the question was already asked.
Because some roads are in French, I have to use French accents like “àéèïù…”.
If I type them in the value of the tag Name of a street in Potlatch, it gives strange symbol in stead (like “é” in stead of “é”). If I write them here, copy them and past in the value of the tag Name of a street in Potlatch, it works fine.
Does someone have an explanation?

Which OS, which browser?

Try pressing ctrl+the character you want.

Ctrl+e brings me to the start-page of my Firefox :stuck_out_tongue:

OS: Ubuntu 8.04
Browser: FireFox 3.0.8
Keybord French.
I actually can’t try anything because the DB of opensstreet are in maintenances,
Thank you for your support.

As you are using Linux and (probably) the Adobe Flash Player, the reason might be this Adobe bug:

That problem was discussed in the German forums recently. Annoyingly, it prevents users from typing “Straße” (street) or anything containing an umlaut. People commonly use workarounds such as typing the words into their search or address bar and copying them.

Not so funny joke: What? There are actually Germans who use the Potlatch editor? Maybe they should start using a real editor, like…uhmm…JOSM!?

As I said ctrl+åäö work fine for me.

An input “é” becomes an output “é”, if the input coding is done according to UTF8 and the result is misinterpreted as utf8 for the output.

So you don’t need another way to type french characters – it’s correct the way you did it.

Perhaps you have changed some character encoding settings of your firefox. Create a new user and try his firefox.

Have fun!

Even though this might work I don’t really see it as a practial thing to launch a new firefox every time I want to edit Openstreetmap.

Surely, but it’s a practical first step in locating the error.

ah yes, but it’s a bug in Adobe Flash. We can’t do anything about it. (well you can if you want to make ugly hacks around it).