Finding addresses

Very new to OSM. Just downloaded (successfully) map for California onto my Nuvi1340. All seems to work except some addresses can’t be found e.g. Glencannon Street in Santa Rosa. However when I look at the OSM map on my computer the address at Glencannon Street is available. Am I doing something wrong with the install? Thanks for any assistance.

Firstly you might like to let us know which of the following providers you decided to download from and the type of map you chose or if you downloaded data from somewhere like Geofabrik and made yor own map using Mkgmap

Hi nevw
Thanks for response. I downloaded from the page link = and took the gmapsupp.img (zip), unzipped it and copied it to the Garmin - initially into the Garmin folder but then copied it to the Maps folder afer taking off previous gmapsupp.img files.

I expect you downloaded from this web site
I downloaded the tile covering the area using manual tile selection and copied the gmapsupp.img to my Garmin Etrex.
As I entered city name… on typing Sant, I was presented with 3 choices (Sant Rosa, Santa Nella and Santa Rosa).
I chose Santa Rosa, California as the city and typed in part of the street name and was offered Glencannon Street and when selected it found the street fine.
I did the search using search all instead of choosing a city and that worked fine too.

I suspect you made the same mistake as me initially and chose ‘Sant Rosa’ instead of ‘Santa Rosa’ which finds nothing.
There does not appear to be a Sant Rosa in the OpenStreetMap so the listing in the gmapupp.img may be something to do with the making of the file in mkgmap or from other maps I have or maybe how Garmin displays the search results?
Hope this helps.

Edit: more specifically, I downloaded the Generic Routable type and I was doing an “Addresses” search.

Thanks Nevw. I think I might try downloading again as I get different results to yourself. On typing ‘Sant’ I get 3 options

  1. Santa Rosa
  2. Santa Rosa Ranch Estates
  3. Santa Rosa West
    No Glencannon Street on any of them.
    I didn’t do the tiles manually just selected California from the dropdown.

A quick thank you to Nevw. I downloaded by selecting the cells manually and the filesize that downloaded was bigger than previously. When I tried it on the Garmin I found the same results as Nevw described and all seems fine now. Glencannon Street in Santa Rosa has returned!