Etrex30 not rebooting after inserting microSD card

I appreciate this forum is more about the maps, but perhaps there is somebody that has a quick answer to this;

I bought a 4GB Sandisk microSD card to expand the memory of my Etrext30.

I inserted the SD card and tried to start up the Etrext, lights up for a few seconds and then shuts down. Took the SD card and the Etrex boots up normally.
Put the SD card back in, hooked it up to my Mac and installed with Mapinstall a card. Tried to reboot, same thing, lights up for a few seconds and then shuts down. Took the SD card out and the Etrex boots up fine.

Any suggestion? Could there be any conflict between maps already stored on the Etrex and the newly inserted SD card? According to the manual i should be able to simply insert the SD card.

Thanks for any suggestions


You can check with if the maps are ok.
Or maybe the SD card is faulty, try to format it first.
Or ask or search for answers at (assuming you are Dutch).

Since you mentioned that you were using a Mac, the problem may be that Mac can
add hidden files to an SD Card which is known to cause a problem when it is
then used in a Garmin device.

I’m afraid I don’t have a Mac and so don’t know any more details.

Javawa has a tool for this:

Thanks for all the suggestions. That tool looks interesting I’ll check it out.
Trawling around various other forum I also ran across a posting that suggested it could be related to the batteries. Changed the batteries for a set of new fresh ones, and presto everything seems to working fine. Not sure, why that would be, but I’m ok and bumming around Delhi once again on my Royal Enfield with the aide of my Etrex and these wonderful maps.