Err, so how does this work?

I’ve got a garmin etrex 20 and came to this website with the idea of downloading opensource maps. I have looked over the website for some time but cannot for the life of me see how to download maps onto the garmin. I can find maps I need and download them to my computer. They come in the form of a .img file. Presumably I then need to copy these to the garmin. But where? There are loads of folders on it. I tried a folder called “Custom Maps” but it didn’t work. I cannot find an explanation of this anywhere. Can someone please help?


You need to put the img for the GPS in a folder called “Garmin”.
See for a good explanation

OK, thanks. So it seems that kmz files have to be installed in the Garmin/CustomMaps folder and img files directly in the Garmin folder.

I now have two img files in the Garmin folder. They both show up as “OSM Generic Routable” under my device in BaseCamp. One shows the map well on my device and in Basecamp. But the other one (“RU-Petropavlovsk-Kamchatskiy”) just shows an outline for the area of the map and no actual data within the map, just the basic map. Any thoughts why this might be?

How did you get the RU-Petropavlovsk-Kamchatskiy tile, just copying the img directly from the site? That probably won’t work.
You have to make a custom mapset first and select the tile, or select the whole country of Russia and compile or download it directly (if it’s already available).

It says on the site “Request your map or download it directly”. I thought I’d just download it directly so I clicked on the link in the left edge of the screen. Anyway I’ve now requested one which I’ll look at once it’s ready in a day or so.

OK, I’ve got the files. It seems that I just need So I download that, unzip it, get an img file and copy that to the Garmin folder on my device. Same result as before - all I get is an outline showing where the map is, but no data within the map, just the basemap showing. I’ve checked and the map is enabled. If I disable the basemap it’s all blank. Am I doing something wrong?