Edited name on map successfully but it is still wrong when zooming out

I am new here and have successfully edited the name of a hamlet in the Cotswolds, England. I changed “Oakridge” to “Far Oakridge”. I noted that the correct name is on the OS maps, and on the road signs entering the hamlet. It is also correct on many other maps. (Oakridge itself is to the west of it and larger and is sometimes called Oakridge and sometimes called Oakridge Lynch.)

The edit worked fine. But when I look at the map zoomed out, it still shows Far Oakridge as just Oakridge, which is incorrect. The editor doesn’t let me edit when zoomed out, and as soon as I zoom in enough to edit, the map becomes correct again.

I wonder if the zoomed out name refers to the name of the larger area, but if so that name needs to be moved to the west of where it is, near to Oakridge (=Oakridge Lynch) itself. At present it makes it look as if it is the name of the place which is in fact Far Oakridge, especially as the text remains small, smaller than the names of the villages.

How do I edit to correct the issue?

It would take some time to render tiles for different zoom level

It has had a day and nothing has changed. I think that the more zoomed out data may not be not accessible for me to correct. Does anyone know how I can get it corrected?

Is there data that we cannot change? Is there some higher authority that does it?

It might take much longer than a day for all tiles on OSM’s “standard” map to change at all zoom levels where that name is visible. Other maps may take longer still - some organisations that “use OSM data” only update their copy very occasionally.

Clear your browser cache or do Shift F5.

If still not visible: send us the url of the object (something like https://osm.org/node/999999 where 99999 is the OSM id of that node.


I cleared the cache, no change, it still says “Oakridge” when in the editor, until I zoom in enough to edit.

If I look at the map itself, I see it is now almost correct, except that some of the name is missing at one zoom level, so it says “r Oakridge” instead of “Far Oakridge”. Here is a link to that position on the map:

But when I go to edit, it says only “Oakridge” and it tells me you have to zoom in to edit. Zoom in and when you finally get it big enough to edit, the incorrect Oakridge vanishes and the correct “Far Oakridge” appears.

Sorry, I don’t know how to get the node number?

Maybe the tile left to the correct part is not re-rendered unless it is marked dirty (either manually or by another change in that area)?

I’ve marked the tile as dirty in JOSM and now it seems to be OK after pressing F5 in the browser.

Thanks, that has corrected the missing characters on the map, but has not fixed the larger problem of what happens when you try to edit that area. It still says “Oakridge” until zoomed in.

Yes, no idea how iD calculates the names in the overlay. Maybe a special tile server?

Yes, the iD editor’s overlay is quite out of date - just ignore it if it’s wrong.

I’m with same problem.
I changed a route that I did with GPS’s informations.
The route changed when the map is in zoom=300m, but when I get zoom=200m the modification does not appear.


Have you tried refreshing browser cache?

The OP was referring to the “Locator Overlay” map in the iD editor. The URL for this layer, as shown at https://osmlab.github.io/editor-layer-index/# would seem to indicate that it is maintained by Mapbox. I tried to ask about this issue here https://github.com/osmlab/editor-layer-index/issues/692 but was insulted by the dev (who is a Mapbox employee) in response, so I wouldn’t hold my breath on any resolution. Edits I did last November are still not reflected in the overlay map so it is not updated very frequently at all.