Edit map with id don't work

I am a beginner to osm and I have started to map with id editor but after that I can’t access the edit mode again I don’t know what is wrong it appears just Whight screen with no maps on it

thanks for help,

I have the same problem, I tried to use another browser but, the problem is still exists.

What browsers are each of you using?

Hi @Doaaelshishtawy and welcome here.

I’m using iD with Google Chrome and it just works as expected.
I can reproduce this with Microsoft Edge. You’ve got to leave Edit-Mode complete, select a new object, then you can edit again.

Best regards

Is this the current WebKit based Edge, or the older version?

I was using Version 114.0.1823.82 of Edge. Now Edge is updating itself. I will do another test.

OK that’s a current WebKit based version.

I suggest somebody that can reproduce it opens a ticket and gives as much information as possible on how to reproduce it. If there are errors in the browser console and you can include those in the report then that would be good as well.

1 Like

Edit: I opened this ticket: Microsoft Edge 114.0.1823.86 (German) No second changeset possible · Issue #9784 · openstreetmap/iD · GitHub

Now with Version 114.0.1823.86 it’s the same behaviour:

After editing the map in iD and saving the edits the button “Edit” (“Bearbeiten”, because I’m using de-DE locale) doesn’t work.

Console: one error
Missing en-US translation: _tagging.presets.fields.address.placeholders.street+place


Buttons must have discernible text: Element has no title attribute

Edit: these errors are not connected to the not working Edit button.

After a clicking “OpenStreetMap” I can select another object of the map and edit that.

Edit: second try to document this for the ticket: it just works as expected. The editor-frame gets white for just a second, but then I can do another edit.

Next try:
If I select a source for my edit - then the Edit-Button doesn’t work.

I’ve been having this happen for a while now in FireFox.

While editing with iD, the entire screen goes white for a couple of seconds then comes back & all good again?

FF 115.0.2 & Win 10

I use Microsoft Edge
Version 114.0.1823.82

i tried with gooogle chrome Version 114.0.5735.199 and still the same issue happen i don’t understand what happen is it an browser version error?

You haven’t got some sort of ad-block or other security plug in going? Never use ID anymore to map but to test how something mapped in JOSM shows in ID. Yesterday tried emulating the events of the OP but Vivaldi is fine, which is Chrome(Chromium) engine based.

I’d try a cookie killer. EditThisCookie, I need to get into a certain mail account, and clean the cookies for the site after visiting. If I don’t just can’t get in again until a browser exit which empties the caches,

With Chrome 114.0.5735.199 I couldn’t reproduce this problem. It worked for me just as expected.
No problems with the new version 115.0.5790.99 too.

Edit: Now I can reproduce the behaviour in 115.0.5790.99 too.
Save a changeset with comment and source - and the Edit button won’t work anymore.

I use Firefox Version 115.0.2

A new version of the ID editor has been released recently ( v 2.27.1 ) and I think the problem is fixed for me, so, what about you folks?