Download Problem

I have a Garmin 2689LMT. I’m trying to download a few OSM panels for Costa Rica onto it, but I’m having problems. The site I’m using is and I’m using the file osm_generic_new_gmapsup which is a zip file of about 2.7Mb. This is apparently designed to be put on a micro SD card. I first unzipped it with WinZip and saved it on my computer as gmapsupp. Then I copied the file onto the SD card and inserted the card into the Garmin. It showed up as a file on the external memory card on the GPS but wasn’t recognized when I tried to use it. I then saved the file directly onto the internal memory where it shows up as a separate file. It isn’t in the Garmin file. The GPS still isn’t able to use it. I would sure appreciate some help figuring out what I’m doing wrong. Anyone reading this has probably figured out that I’m in kindergarten when it comes to computers, so simple goes a long way. Thanks for any help that can be offered.

Try to put the gmapsupp.img (please note that the file needs the extension .img!) in a folder called “Map”, not in the “Garmin” folder

Your suggestion worked. Simple as it was, I never would have figured it out, especially the extension, so thank you very much! As the extension isn’t added to the file when it’s unzipped, is this something that would be useful to put in the download instructions on the website?

If you unzip it properly, the extension is kept. It is already mentioned in the FAQ that you need to keep the extension *.img: