connection expired on, fine on


I’m working on a small mapping application as a hobby project (nothing huge, mainly doing this for learning about UI, UX and in the case of OSM http requests) I’m using Qt, and up until now I was requesting tiles from MapQuest (otile[…]…) without any problem. In my test, I create a request with the full url (for instance : and send it, then I get the answer just fine.

The problem is that I wanted to test other tile providers, such as OpenStreetMap and CartoDB (I really like the Positron looks :p) When I try the exact same code (except the URL obviously) then I get an error 99 - connection expired. The strange thing is that if I copy / paste the URL into a browser, the tile display just fine.

So I think it’s got something to do with how my request is created, maybe the header ? I found this page : So I tried to add a user-agent (this seems to be the only “mandatory” header to provide) but that didn’t change a thing.

Also, if my application was blocked (which I doubt since I’m only making 1 request every few minutes) I should still get a tile, only a tile saying “access blocked”, if I trust the wiki page :confused:

So here I’m completely lost as to why I only can get tiles from MapQuest. If anyone has any idea of what I might be doing wrong, suggestions, questions for more details on how I’m doing things, etc. feel free to answer :slight_smile:

Damien Courtois

Hi again,

In case anyone has the same problem and stumble on this post: it was a “simple” matter of proxy, or something similar. I installed OpenVPN on my computer (at work) and now I can get tiles from all sources.
I still don’t know why it worked with MapQuest but not the other 2, but now I can continue working on my project.