Coming to terms with OSM editing


I have been battling my way through OSM and learned to add a mountain (do not use Polatch 2 but 1 instead) and taking a GPS plot and converting it to a walking track. But if someone could look at the Mount Victoria Track that I put to Mount Victoria in Tasmania Australia and advise me why part of it shows and other bits do not in view mode and how I set the zoom level at which it seen at. Basically, I am trying to comply with “standards” but simple things like “route” = “hiking” is not recognized by Polatch 2 but Prolatch 1 does not give me the aireal photograph Polatch 2 does. As for JOSM, well downloaded it and click on it and was told by Microsoft to download Bitzipper. Did this and it was not recognized. Gave that away as a bad idea. Also I added to lakes, Oenone and Helen in Tasmania Australia but again have no idea why they do not appear on zoom levels.

Polatch 2 seems to be a half baked child of Polatch 1. Likely very unfair comment but getting information is rather disjointed. I would like to comply to standards such as what information should be provided. Bit like street naming. Do I set the speed limit for each street or do I use a code to set a category for local street?

Any help or pointers would be useful.


Firstly, sometimes the map on can take a while to update - sometimes minutes, hours or even a few days. And it might update the tiles at some zoom levels, but not others. Usually if you wait a while, it should look correct at all zoom levels. Or you might be looking at a cached version, try Shift+Reresh in your browser. If there is a specific thing not appearing, then post a link here (use the permalink option, then copy the URL).

Also, I would recommend using Potlatch v2, not v1. v2 is better in many ways, and usually easier to use, and less likely to mess things up. v1 is now pretty much obsolete, I think it is best avoided.
If you have any specific problems/questions about Potlatch v2, fee free to ask here (or on ).

As for route=hiking, it is usually used for waymarked long-distance routes, made up of a number of different paths, tracks etc. You don’t usually need it if you are just mapping an individual path. And the route=hiking tag should be on a route relation, not the separate ways. And you can add paths to a rote relation in Potlatch 2: select the path, then choose the tab for “Walk”. Then you can add it to a national walking route / regional walking route etc.

Also, as for JOSM, you don’t need Bitzipper at all. But you will need to download and install Java if you don’t already have it (from ). Then downloading the JOSM file and clicking on it should work.

Hi Vclaw

Thanks for the reply. I will follow through on the advice. Handy to know a few concepts and the way to run with the updates, etc. Been gradually working on the skills to build up a walking track database in Tasmania and also doing a bit of street naming and correction. Struck and interesting thing with Google maps when I was playing with that. It has a few street naming errors as my friend’s street has moved location! At least with OSM I can correct such errors but generally found data for when there accurate.



Well Java installed and problem fixed there. Used Control+Shift+R and screen updated. Happy camper as track shows up nicely. One down and hundred more to go.


I wouldn’t say that v1 is totally obsolete. It’s quite handy when searching for existing relations. In v2 you have to know the relation ID, while in v1 you may use either the ID or a relevant word (the name of the relation or a location). Yesterday I found out (with the help of v1) that there was no adminlevel 8 boundary relation for Valkeakoski town in Finland, so with the help of v2, that town has now got a starter of it’s boundary.

And with v2 there is an annoying feature within the selection field for relations. When editing relations, v2 automatically “collects” relations found en route. Not long ago was I editing a bus route starting near Jyväskylä city centre. When I reached the city terminal, v2 relation selection field carried almost 200 different relations. The annoying thing was that listing wasn’t “static”, but the order of those relations changed constantly. So I had to scroll and search for the relation I was working with. In this case v1 is also handier, since the relation listing is “static”.

My wishlist for v2:

  • the relation search function is made better, similar to the one in v1
  • as an advanced way of editing relations, there would be a button (or something similar) that disables the automatic search for and addings of relations en route - so the only relation shown in the “select relation” windows of v2 is an elected relation

Well crashed and burned on JOSM. Java installed and it installed but get “Editing failed - make sure JOSM or Merkaartor is loaded and the remote control option is enabled” error. Well might be a good thing as coming to terms with Polatch 2. Still a lot to learn.

Interested in joining a local group for Australia/Tasmania but while they exist the joining protocol appears elusive to me.

Also experimenting with Bit Tin Can Mapper for adding data but it appears to be limited to points of interest. Named a few today so interested to see if they turn up. Actually looking for a decent iPhone app to help out on the ground mapping. I use a Garmin 62S for bushwalking and having tested it in a GPS shoot-out it ranked king but definitely home base work required to do some simple things.

Notice that some changes take a while as mentioned to filter through, but all have eventually appeared.


Hi Ent

JOSM can be a bit daunting at first, but it’s worth sticking with if you plan to do a lot of mapping, as (for me at least) you can build up a quicker workflow, and there are lots of useful tools and plugins for it.

I think that error would have appeared when you clicked on an Edit link on the webpage somewhere, hoping that the browser would pass the details through to JOSM. For me, that command gets blocked by Firefox’s security (ABE), so maybe that’s your problem.

However, you don’t need to do it this way. Just manually start JOSM (run the JOSM.jar file, located wherever you installed it), and then click the ‘Download map data’ button (3rd from the left on the main toolbar for me), or File->Download from OSM…

To get the aerial background image, use the imagery menu, select a server and then wait a few seconds for it to download and appear. Note that in the layers window on the right, you can use the button that looks like an eyeball to toggle the layers on and off, and I find that turning down the opacity of the aerial layer (using the next button along) to about half makes it easier to see what you’re editing. If the first server you chose isn’t any good, use the trashcan button to get rid of it and try another one.

Not sure how your GPS records data, but if you end up with .gpx files, open these (using the first button on the left in the main toolbar, or File->Open) and the track will appear on it’s own layer. If your GPS (or whatever phone app you end up with) enables you to record voice memos, then you might get a wp.gpx file - opening this will show little icons all over your map. Clicking on one will play the audio clip or show the photo or whatever. Dead useful.

You’ll have to get used to dragging the map round with the right mouse button in JOSM. S is a shortcut for select mode, A is a shortcut for add. I could go on, but it’s probably easier for you to just play around with it.

Stick with it. As you start to use it, you’ll discover all sorts of useful stuff in there.

Good luck


If you want the edit links to work, you need to enable the “Remote Control” feature in JOSM. Start JOSM, then go to Edit menu → Preferences, then click on the remote control icon (probably the 9th icon down the side). Then you can tick the box for “Enable remote control”.
Then restart JOSM, and those Edit links should work. Note that JOSM has to be running before you click on the link.

I was going to mention the remote control plugin but that’s already covered.

For the easy starting of JOSM I’ve put a shortcut on my desktop with the OSM logo as the icon.


Mental stability rating returning to normal.

Ok figured out what everyone was saying. Started JOSM and then select edit after I enabled the remote option in JOSM. Took me a while to figure out where JOSM lived on my computer. So use to programs being installed it took me a few head bangs to realize it almost acts like the .exe file of old, so shifted it from the download directory to my OSM directory. Short cut is coming real soon to my computer.

Now JOSM. I think I will stop complaining about how complicated Polatch 2 feels. Took me a while to even move the screen in JOSM! OK right click and move mouse. Next mental challenge was finding where the drop points lived. Found them without resorting the rum. So now I added a building and uploaded the changes and ready for a rest. Cheated and used Polatch 2 to give it an address. Now if I understand Bing is probably for Tasmanian the best photographic template but I have noticed it does not line up with my GPS plots well and also found on other people’s work when using my Garmin 62S it wanted me to turn off a road as I was heading the wrong way. The road was a split carriageway and likely not place quite right. Need to brush up on the photo offset feature. Any clues? Also avoid the temptation to move stuff to match the photograph as I have done in the past with streets as the street might be right and photograph is off.

Ok been experimenting with Bit Tin Can Mapper to add points of interest. One word describes it. Clunky. Is there any better iPhone app for uploading data in the field? Normally I use my Garmin 62S as a data logger but this involves lot of manual work on the computer when I get home. I have added a few bushwalking tracks (ok hiking trials as my USA cousins would say) and quite proud of that. Um? have not tried it but can you route walking paths? The Garmin appears to kill the iPhone for accuracy yet on commercial products the the iPhone if held in the hand gives impressive results. Might be Bit Tin Can is a bit of a tin can when it comes to GPS performance.


Hi Ent

Glad you’re starting to come to terms with JOSM.

Just one thing I’d caution against is automatically assuming your GPS tracks are more accurate than the photo. They might be, but quite often consumer-grade GPS devices with their tiny aerials can be up to tens of metres out, especially when there are lots of buildings around.

However, the photo might be off slightly too. I shall read with interest the replies regarding that, as that’s something I’d like to learn more about.



As mentioned I am using Garming 62s which is pretty good with a clear view of the sky and does a good job in more crowded environments but it is far from being professional grade. I use the iphone for adding points of interest but with Bit Tin Can Mapper as mentioned it is not brilliant yet with another GPS APP it does well when compared to the Garmin 62s. A few weeks back a friend and I did a GPS shoot-out. It was interesting how I iPhone performed depending on the App. Of course the Garmin 62S killed them all.

Still hunting for a good iPhone App so I can do some work in the field. Working on the Walls of Jerusalem area in Tasmanian and adding lakes at the moment. With Polatch 2 a rather time consuming job using the Bing photographs. Was hoping if anyone could give me tips on using JOSM for that task. Reading the help I gather Polatch 2 is preferred for adding tracks. I can now split and join tracks and finally figuring out some of the features of Polatch 2.

Anyway any help on the best iPhone App for OSM data recording and even an encouraging phrase that entering lakes can be automated would be great.

And thanks for all the replies.


I haven’t used Potlatch V2 because I started with JOSM right at the beginning after fumbling around with PL V1 and really not liking it.
I spend quite some time fixing errors cause by Potlatch, the most common of which is small roads meeting a main road and not actually joining the main road.
JOSM has a data validator that it runs before you upload your edits/additions and that kinda stuff is highlighted before you even upload it.
Visually it’s not necessarily a problem but it drives the auto-routing algorithms mad :wink:
Potlatch 2 may be better, but I still say stick with JOSM if you can.

One last point, sell the iPhone and buy an Android phone hehehe.

Um? Android, like a Motorola Defy that has that name because it defies anyone to get it to work for more than a day without crashing! Or a HTC that you have three, one to use and two in repair. Maybe just me but the iPhone works.

Anyway back to the serious stuff. I am either rather inept or OSM tends to force you to use Polatch 1 for adding mountains? Getting the hang of Polatch 2 which is good for splicing and joining GPS plots. Will start more on on JOSM when I find out more about adding lakes. This is a rather tedious job I am finding under Polatch 2.

I have been working on mapping a favorite walking area called the Walls of Jerusalem, in Tasmania Australia and it is a national park. I have noticed traces of a park boarder in places and wondering what I need to do to join them up and map the stuff in it all part of the national park. As always any help or pointers would be appreciated. More interested in concepts, i.e. best done it this way rather than detailed instructions as I am having reasonable luck tracking down the how-tos.


Its true that Potlatch 2 doesn’t seem to have a preset or icon for mountains. But you can still add them (or any other tag that is not in the presets): Double click on the map to add a node. Then click on the button at the bottom of the side panel for “Advanced”. Then you can type in the tags. For a mountain, type natural for the key, and peak for the value. You will probably also want to add a tag for name, and ele (for the elevation).

Or use JOSM, which has peak available as a preset.

The boundaries of national parks should be tagged with boundary=national_park, see
National parks are usually rather large, so the boundary will probably be made up of a number of ways. In which case, you will need to use a boundary relation, with the individual ways as members. See

As far as I know, there is no feature in OSM for “mountain” - there is a proposal but it is not a current feature.
Lakes in JOSM:
I would just trace the outline of the lake, make sure it’s a closed polygon.
Then add the Tag(s)
natural=water and

Or if it’s man made:

For a national park, you would do much the same.
Trace the border, again make sure it’s a closed polygon.
Then you have various choices for landuse=forest or natural=wood, etc. etc.
Add the name tag name=xxx
The whole area within the polygon will be rendered on the map with the name somewhere in the middle.

You mentioned Bing alignment in an earlier post but I missed it the first time.
They are not perfectly aligned, as I’m sure you’ve discovered by now.
The alignment offsets also can be different at different zoom levels.
Adjacent tiles at the same zoom can have (often) quite large different offsets.
If you have a decent GPSR, it’s likely that the tracks you record will be more accurate than the Bing images (in my experience of mapping in Thailand)
Especially if you are out in the open and there are no buildings around.

Hope some of that helps :slight_smile:

Thanks for all the pointers. Gradually getting better at mapping and then when I discover something have the “joy” of going back to correct the clumsy “solution” I used before.

On Polatch 2 for mountains I had dropped to the idea of using the advance features and adding;

name=Some peak name
elevation= elevation but appears to be a text field. Now no great disrespect intended but as a generation of Australians that was forced kicking and screaming at near gun point to adopt the metric system (imperial rulers were actually made illegal to sell!) I am rather amazed that you can not enter a number with a unit of measurement and then for our USA and English cousins they can have it in their beloved feet (what ever shoe size measurement system they use)

I celebrated by naming a few peaks and they did not show up. I waited a period of time as changes take a while to come through and nothing. I then used Polatch 1 and it worked. Puzzlement abounded.

Using Polatch 2 with great success for tracks and gradually sorting out a few concepts but still have not mastered the route concept. Taking the Walls of Jerusalem area (It is a National Park that has many features named from the biblical locations by the early explorers. This technique is common in Australia with a cave system having features named from a classic poem and subdivisions after WW1 battles or Generals. So please note, to me they are just names, not an advert to a belief system) I have track called Mount Jerusalem track but with a side track called Hells Buttress Track. I have joined them at a node but are curious what is the effect as a routable track? I have yet to head back there and play with my Garmin but curious what will happen. In walking mode the Garmin 62s seems not to acknowledge tracks but in automotive mode does.

In heavy scrub you need every bit of help sticking to a track as with cloud and limited view of major features means you soon lose perspective where north is.

Also can not figure out is it possible to have OSM combined with contour lines. Now I downloaded GPS-Track for the iPhone and it gives the ability to use the cycle maps which come up with 20 metre contour lines. Great but no walking tracks that I created showed up. Nor roads for that matter. As always any pointers would be great.

It is actually great to see an area gradually take shape. The GPS often is more accurate than the photographs but sometime they match very well. Question on Bing. In Tassie it is rare to get a cloudless day so often cloud obscures the photograph. Are Bing photographs for ever or are they updated periodically?

i will see if I can track down the national park boundaries. I believe that my challenge will to get this data from a non copyrighted source. In Tasmania we have a rather “protective” state government bureaucracy and rather not have OSM run foul of this little group of Vogans (reference from Hitchhikers Guide to the Galaxy that describes bureaucrats).


The tag for mountains is natural=**peak ** (not “nature”, and not “Natural”). It has to be the correct spelling, and correct case (note OSM tags are usually all lower case), otherwise the map renderer doesn’t know what to do with it.
And the tag for elevation is just ele. The value for elevation should be in metres, and just the number, without specifying the units.

This may depend on what Garmin maps you are using. Some support routing, others don’t . Also check how up to date they are. I can route along paths with OSM maps on my Etrex.

This depends on the app, and what maps it is using. Some apps update the maps very infrequently, so maybe months out of date.
Have you seen the cycle map on Click on the layer switcher in the top-right corner of the map. It includes contours.
Or you can get contours maps in Garmin format, and combine them with OSM. eg see (not sure if it covers Australia). Or you can make your own Garmin contour maps.

Yes, Bing aerial imagery is updated occasionally. Though I don’t think there’s is any fixed pattern to it, it will vary around the world, depending on what sort of imagery is available. And sometimes the ‘updates’ are worse quality, with even more clouds etc. They recently launched a lot of new imagery, but there is still plenty parts of the world with only low-resolution or out of date imagery. See

Hi Vclaw

Um? Victim of my own crummy spelling yet again. O’well back to revisiting the maps to sort that little muck-up out. Thanks for the links. Plenty of reading to do. I will check out the links.

It was good to get into the Aussie group to start applying standards to road classifications. My aim is to do quality work to avoid others having to rework the area. Must admit in Tassie rather few mappers out there. By the looks of the names used much of the state has been done by tourists with more than a few incorrect names and assumptions on where and how roads join but still great to have their work as a framework to build upon.

Fell victim to my tendency to be overly precise when defining a lake. Was using Bing at maximum resolution and the Lake was moderately large so after many clicks and 46 minutes later the save failed. Ok, I was warned so next step was to figure out how to split this up and and save every five minutes. Was rather chuffed but then found the reason for the original failure. Polatch 2 or OSM only allows a track or object to be a maximum of 2000 points. I did say I was being rather precise!

Just as a aside, I take it Vclaw that you are Scottish based on your location place name. One of my older walking companions is from Scotland and so was a few distant relatives of mine. Not sure if they were exported or deported. Anyway, thanks for the help.

The cycle maps are what I am after but they never seem to have been updated since I started on OSM. Also the message “Cycle maps” coming appears on great chunks of the area that I am looking at.

The aim is a planned walk to Lake Artemis to check out the Greek named part of the park. Being a remote area (two to three days in) looking to map the place as once up there it is trackless. Nothing like mapping a place to get a feel for the area.

Waterways is something I would not mind tackling but they have both a characteristic of a track but also can have a significant volume so not sure how they are treated. Creeks are only a metre or less wide but some rivers can be many times wider. As a bushwalker this can be rather important information.



I have being rather lake bound in the “Land of a thousand lakes” (and they were not lying about that!) in gradually building up a map. Now I know that Bing can be out so when walking the area I will be checking against my GPS the error with the idea to move features when back home. But what is stopping me mapping islands is working out if an island can be linked to a lake so if I move the lake then the island will follow. I read the ancient geek OSM instructions and found them rather challenging and the result was not what I wanted.

Here is what I did in Polatch 2

Draw the lake as normal and gave it natural=water and the relationship=multipolygon
Then draw the island and gave it natural=scrub (would prefer something more generic like land but it needed something)
Then selected both and clicked the little box with a box in it.

I then selected the lake and moved it. The island appeared to move but when I let go only the lake had moved and the island remained in place.

Basically can you set up a relationship between the lake and its islands so if you move the lake the islands will follow? Also can I use a more generic term than scrub?