Can't login or register to system that has deployed remotely

Hi team,

I deployed the code base under aws apache server and I followed instruction at as it is. Now every thing seems to be ok, but I got an error when I tried to register, login and diary. The error message is at bellow. Please try to give the solution :frowning: :frowning: :frowning:

Application error
The OpenStreetMap server encountered an unexpected condition that prevented it from fulfilling the request (HTTP 500)

Feel free to contact the OpenStreetMap community if your problem persists. Make a note of the exact URL / post data of your request.

This may be a problem in our Ruby On Rails code. 500 occurs with exceptions thrown outside of an action (like in Dispatcher setups or broken Ruby code)


Sorry, this forum is not some kind of support help desk.

Did you follow the configuration steps?

Just to take a step back, what problem are you trying to solve? It may be that for what you want to do deploying a copy of might be the solution, but often people trying to do that are really trying to solve another problem altogether. If you could explain what you’re trying to do we may be able to suggest an alternative that is much easier to set up.

what i did is

  1. follow the steps on as it is in local machine and it woked without any issue (login, signup worked)
  2. Then I tried to do the same on server with the help of “Phusion Passenger”.
  3. Now it will render the map , but when i try to edit, the system will navigate to login page, then I try to create a account, then it will generate an error that i mentioned above