building outline with building:levels=0

Hello !
It seems there’s a problem with kendzi3d where the building outline is rendered quite high, and some mappers started setting building:levels=0 to work around it.

source here:

Any idea on that ?

Fix the default height in Kendzi3d?
Maybe 0.5 of the level height?

The same is happening with as well. According to the wiki that is wrong.

In this issue there is a relation mentioned as possible workaround. What do you guys suggest? outline with building:levels=0, creating a relation like mentioned in the issue? It seems osmbuildings is not able to solve the problem, therefore the building:levels=0 for the outline would be the easiest solution right now, am i wrong?

Yes, you’re wrong. That’s only “mapping for the renderer” and a bad idea :frowning:

Jan does mention an intersection test functionality in that issue, so does OSMBuildings lack the functionality entirely or only in certain circumstances?

The problem with adding building:levels=0 is that it would mean adding incorrect data for the benefit of a particular data consumer (sometimes called “Tagging for the renderer”). Other applications could be negatively affected, including ones unrelated to 3D.

Adding a building relation, on the other hand, may be unnecessary for software that implements intersection tests for the areas, but it isn’t incorrect. So that would be my preferred solution if you want to work around this limitation.

You are both obviously correct. As i try not to tag for the renderer at all i just did not see, that building:levels=0 on the building=yes part itself would be exactly that. Thanks for pointing that out.

Might try with the relation maybe.

Good question, will check in that issue on github. Thanks for pointing that out as well.

Kendi3d should have an option “Hide building outline”.

Well, kendzi is just broken with an recent java. It seems like Java6 is needed, otherwise its not working and shuts down JOSM. There is an issue but the project seems abandoned.

I just want to ask, OSMBuildings is wrong in this case and should change their rendering or their detection if an building:part=yes is present? There is already a issue about that but it does not seem like there is any movement