Browser Problem with mapnik

since a few days I see with Firefox and Mapnik as renderer only a white page.
With Osmarender it works and with IE is also the Mapnik-style map viewable.
I have the newset Version of firefox and until a few days it had worked.
What can be the reason?

Edit by Lambertus: Mapnic → Mapnik :slight_smile:

Try clearing your browser cache because both maps work fine with me (FireFox 2) so it’s probably something on your side of the net.


thanks for the reply. I flushed the cache, but the problem still exists.

Sorry that didn’t help…What is your version of FF? Also, which URL’s are you trying to open but do not work? Can you post a screenshot?

I open, The site looks ok, except that the map window is blank white. (Sorry, don’t know how to include screenshot here, ctrl v don’t work)
The problem is only with Mapnik and only since a few days.
When I change the renderer from Mapnik to Osmarender it works again. Also with IE and the firefox at work I have no problem. Only my FF at home has difficulties, also I cleared the cash and I can’t remember changing any settings in the browser.
FF Version

Hmm, I haven’t got a clue what is wrong here. Again, I have no problems with the Mapnik map with FF2 (same version as yours).

Does the statusbar of the browser give you any clues? Mine says ‘waiting for…’ quite long while having a blank screen. After that it starts loading the tiles which takes some time as well (depending on how busy the server is and your internet connection). Maybe you need to wait a bit longer?

Thanks for your replies,

unfortunatly it’s not the loading time, there is no loading remark, and even if I wait half an hour (i have a Dsl-connection) there is still the blank map.
I think it nothing to do with osm nor with FF, nor with my pc (for with IE it works) I think it’s only a problem with my special FF-installation, although it previously worked. I’m afraid I have to reinstall FF.

Reinstalling FF because Mapnik does not work? Is Osmarender, informationfreeway, freemap and others not enough? :wink:

Hello Lambertus,

I’ve solved the problem. In the settings of FF in the tab content there is a menu “Exceptions” where you can define explicitly websites which are not allowed to load graphics. There was an entry for OSM! Don’t ask me how this entry came into this menu. Really strange.

:slight_smile: I’m glad your problems are solved!