Bitte um Hilfe bei Radwegreparatur

Hallo, ich mache das zum ersten mal, und offensichtlich mache ich trotz aller Sorgfalt irgend etwas falsch. Es geht um einen kombinierten Rad- und Fußweg. Das vorgefundene darunterliegende Polygon hatte bereits die korrekte Markierung “bicycle=yes”, diese wird aber beim Routing offenbar nicht berücksichtigt. Also habe ich explizit einen Weg darübergelegt, und ihn mit den beiden anderen Wegenden verbunden, und diesem Segment die gleiche Markierung verpaßt, die auch das Polygon hat: “bicycle=yes”. Als noch immer nicht korrekt geroutet wurde, fiel mir bei genauem Hinsehen noch auf, daß schon das erste Segment des Weges nicht an den Ruhrtalradweg angeschlossen war, sondern wenige Millimeter davor ebenfalls an einem solchen Polygon endete. Auch das habe ich ergänzt.

Trotz aller Bemühungen wird nach wie vor über einen fast 1km Umweg durch den Autoverkehr geroutet, obwohl ein direkter Fuß- und Radweg existiert und der auch eingezeichnet ist. Was mache ich falsch, oder besser gefragt, Muß noch irgend ein zusätzlicher Schalter umgelegt, ein Flag gesetzt werden, damit diese Route auch gefunden wird und der Weg nicht weiterhin ignoriert wird?

Siehe Bildschirmfotos:

Vielen Dank!

(Als neuer Benutzer darf ich wohl nur ein Bildschirmfoto pro Text anhängen, hier also das zweite.)

Beim Navigieren kann das immer ein wenig dauern bis die Datenauswerter auf den neuesten Stand aktualisiert haben. Warten hilff? Tage?

1 Like

Die Links zu den genannten highway :
(A)
(B)

Routing mit den anderen Routern funktioniert auch nicht über (A) und (B) - auch nicht zu Fuß ,
aber funktioniert über direkt angrenzenden (C) .

Handelt es sich vor Ort bei (A) , (B) und (C) um einen beschilderten Weg?
z.B.:
Gehweg mit Fahrrad frei?
Oder vielleicht gemeinsamer Geh- und Radweg?

Die Daten sehen OK aus, sollte je nach Router in spätestens einer Woche richtig funktionieren.
Off Topic: Diese Sammerelation scheint mir aber verdächtig: https://www.osm.org/relation/2073184
Was soll damit wohl erfast werden? Alle Radwege in NRW?

Wenn ich mir da die Umgebung ansehe, scheint da einiges im Tagging inkonsistent zu sein:

  • Way: ‪Ruhrstraße‬ (‪233279149‬) | OpenStreetMap ist eine Kombination aus living_street (so beschildert) mit service=driveway, zudem unnötigerweise foot=yes und noch irritierender bicycle=designated
  • Way: 264592433 | OpenStreetMap ist als path gemappt mit foot=designated und bicycle=no Das klingt nach einem Fußweg mit VZ 239, also eigentlich schlicht (kiss) highway=footway
  • Way: 517967564 | OpenStreetMap ist hier der Radweg tatsächlich “unterbrochen”? footway mit bicycle=yess heißt für mich VZ 239 mit Zusatzzeichen Radfahrer frei
  • Way: 430399230 | OpenStreetMap wenn hier VZ 239 mit Zusatzzeichen Radfahrer frei beschildert ist, dann braucht es kein segregated=no. Oder das segregated=no weist auf VZ 240 hin, dann wäre es aber highway=path, foot und bicycle jeweils designated… Im Übrigen fehlt m.E. die Anbindung an den Fußweg, sonst routet es Fußgänger immer am Rand des Platzes lang.
  • Way: 295481640 | OpenStreetMap das Gleiche wie zuvor - genau nach Beschilderung mappen. Zumindest die weitere Anbindung an den Fußweg ist da.

Vermutlich, aber das sollte in einem eigenen Thread diskutiert werden.
Im Kreis COE habe ich das Grundnetz bereits auf lcn Tags am Way umgestellt.

access:both_ways= no ?? Way: ‪Mühlenstraße‬ (‪204537439‬) | OpenStreetMap

Fußrouting über die Fläche (die in Ufernähe) geht natürlich auch nicht:

Die Radwege dort sind reine Radwege (foot=no).

Und hier ist auch noch was zu tun… :wink:
(Jede Bahn ist ein eigenes kleines Multipolygon, der Künstler der das vor 9 Jahren eingetragen hat ist gottseidank noch aktiv in OSM).

3 Likes

Der gesamte Weg (einschließlich der polygonalen Fläche, die das Routingproblem verursacht hat) ist zwischen dem Ende des Stichs der Mühlenstraße und dem expliziten Radweg entlang der Ruhr mit Schild 1022-10 (Fahrrad frei) in Verbindung mit Schild 239 (Gehweg) ausgeschildert. “Key:segregated” kommt also hier nicht in betracht. Ein Absteigen (Key:bicycle=dismount) ist nicht gefordert.

Ich denke, ich habe die Flags richtig gesetzt.

Die Relation 2073184 habe ich zu diesem Wegstück, das ich über das Polygon gelegt habe, nur hinzugefügt weil die vorhandenen “Anschlußradwege” auch damit ausgestattet waren, und ich (vermutlich fälschlich) davon ausging, daß dieser Eintrag für die korrekte Funktion des Routings erforderlich ist. Ich hoffe, das war kein Fehler.

Habe den Fußweg jetzt so verlängert, daß er mit dem Fußweg, der parallel zum Radweg direkt am Wasser verläuft, verbunden ist. Jetzt sollte das Routing auch dafür korrekt funktionieren. Die gesamte Fläche des Polygons ist “Fußweg, Fahrrad frei”. Die einmündenden Radwege haben davor ein paar “Bremshubbel” quer über den Weg.

Foto der Situation vor Ort: Der Herr benutzt korrekt den Fußweg, die Dame läuft auf dem Radweg, der vor dem Polygon mit “Bremshubbeln” ausgestattet ist.


Die Stadt hat wohl vergessen, den Fußweg von den Gebäuden kommend über die Grünfläche hinweg mit dem Fußweg am Wasser zu verbinden, sodaß die Leute entweder durch den Matsch über die Wiese laufen müssen, oder eben den Radweg blockieren. Das kann OSM aber nicht beheben, wir können nur abbilden, was da ist.

OT: Wenn das Routing über Polygone nicht funktioniert, wie viele Stellen in OSM müssen denn dann jetzt gesucht und korrigiert werden, bei denen bicycle=yes nur für so ein Polygon eingetragen ist, ohne noch zusätzlich einen Weg darüber zu legen? Kann man die irgendwie systematisch aufspüren, um sie in einem Rutsch zu berichtigen? Oder werden das Zufallsfunde bleiben, wie dieser hier, also quasi ewig ein falsches Routing verursachen? Ein Einzelfall, oder ein Massenphänomen?

Bei einfachen Nicht-MP Flächen gehen die meisten Router am Rand der Fläche.
Die vorliegenden Flächen sind aber Multipolygone.

Foto der Situation vor Ort: Der Herr benutzt korrekt den Fußweg, die Dame läuft auf dem Radweg, der vor dem Polygon mit “Bremshubbeln” ausgestattet ist.

wie sollte man erkennen dass das ein Radweg sein soll? Der Weg fängt augenscheinlich dort an der Fläche/Querung an und es steht keinerlei Schild, oder?

Bis vor einiger Zeit waren alle Polygone entlang der gesamten Radweganlage an der Ruhr in Herdecke noch so ausführlich und eindeutig beschildert:

Vollständige Beschilderung der Polygone.
Neuzustand Beschilderung

Das hat wohl alles das letzte Hochwasser weggespült? Oder wollte einfach nur jemand den angeblichen deutschen Schilderwald lichten? Keine Ahnung, seit wann die Schilder und Markierungen auf dem Boden teilweise fehlen und ob wann sie wieder ergänzt werden. Auf der Gesamtstrecke werden sie jedenfalls oft genug wiederholt, so daß Fußgänger und Radfahrer hier schon sehr genau wissen, welcher der beiden Wege als ausschließlicher Fußweg, und welcher als ausschließlicher Radweg ausgewiesen ist; diese strikte Trennung dient nicht zuletzt der Unfallverhütung.

Keine Ahnung, seit wann die Schilder und Markierungen auf dem Boden teilweise fehlen und ob wann sie wieder ergänzt werden. Auf der Gesamtstrecke werden sie jedenfalls oft genug wiederholt, so daß Fußgänger und Radfahrer hier schon sehr genau wissen, welcher der beiden Wege als ausschließlicher Fußweg, und welcher als ausschließlicher Radweg ausgewiesen ist; diese strikte Trennung dient nicht zuletzt der Unfallverhütung.

ob sie weggespült wurden oder absichtlich entfernt kann ich nicht beurteilen, aber wenn die Alternative zur vermeintlichen “Radwegbenutzung” ist, dass Fußgänger über eine matschige Wiese gehen müssten, dann kann ich mir gut vorstellen dass dort absichtlich kein Radweg beschildert ist, auch bzw. erst recht, wenn “auf derselben Strecke” sonst grundsätzlich Radwegschilder sind.

Eventuell ist access:lanes:both_ways gemeint.

Am besten wird es @skyper wissen, was gemeint ist :slight_smile:
Auf Mapillary (Aufnahmen eines Künstlers :smiley: ) sieht es nach einer Folge von Linksabbiegerspuren aus, d.h. eigentlich überall wie das Stückchen zuvor: Way: ‪Mühlenstraße‬ (‪239061149‬) | OpenStreetMap, stets lane:forward=2 mit turn:lanes:forward=left|through

Es wurde nach mir gerufen. :smiley:
Als erstes hat das nichts mit Radwegen zu tun. Daher ist es off-topic und sollte wohl in einen eigenen Faden “Was bedeutet access:both_ways=*” verschoben werden.

Allgemein stammt :both_ways vom Spurtagging und ist für Spuren in der Mitte der Straße welche für beide Fahrtrichtungen verwendet werden. Analog zu :forward und :backward kann :lanes weggelassen werden, wenn sich der Wert auf alle Spuren dieser Kategorie (both_ways) bezieht. Beispiele sind destination:forward oder maxspeed:backward. Ein access:lanes:both_ways ist auch OK aber länger und bei nur einer Spur nicht nötig.

Ich hatte damals versucht die Geometrie der Straße möglichst genau einzutragen. Da es sich nicht um eine Linksabbiegespur sondern mehrere mit Unterbrechungen handelt, hatte ich die Sperrflächen mit lanes:both_ways=1 und access:both_ways=no eingetragen. lanes=2 hatte ich gelassen, da es sich nicht um wirkliche Spuren handelt, jedoch wurde das mittlerweile leider in ein falsches lanes=3 geändert. Bei befahrbaren Sperrflächen setzte ich noch ein emergency:both_ways=yes, was hier aber nicht der Fall ist. Das ganze sieht dann so (etwas runterscrollen zu den aneinander hängenden Stücken der Mühlenstraße) aus.

Insgesamt hat die Mühlenstraße ja etliche begrünte Mittelstreifen und sowohl am östlichen Ende als auch weiter westlich vor dem Kreisverkehr würde ich sie in Einbahnstraßen aufteilen. Für eine kleine Verkehrsinsel, wie an den beiden Zebrastreifen, finde ich das allerdings übertrieben.

3 Likes

Der Fehler liegt woanders. Leider wird das Routing-Profil von OSRM immer wieder umgebaut und dann kommen zeitweise so komische Strecken heraus, wie hier:


(GraphHopper (2,0 km) & Valhalla (2,1 km) machen es hier richtig (statt 4,2 km))

Man sollte bei solchen unerwarteten Ergebnissen daher auch andere Router probehalber nutzen.