Bits of road missing

This seems really weird. Recently I started editing roads in Indonesia. Now I find that parts of some roads don’t get rendered. Take a look at this example with Osmarender:

With Mapnik there is even less:

The data was added 6 days ago and shows up in the data layer. If an entire way was missing I could understand that, but just bits of it, cut off neatly in a vertical line? There are other roads missing small sections, all near junctions, never in the middle.

Maybe this is related: usng the latest stable JOSM sometimes I can’t select the end node of a way. It just doesn’t show. When I try to move the node the entire way gets moved. Is this a bug? Faulty GPX data?

Any help is appreciated. I have lots of collected data for Asia.


The pieces of the road are not missing, but not rendered. I ran Osmarender on the tiles with “holes” in the road, so with Osmarender it should render now correctly.
Mapnik is rendered each wednesday, so you will see your way appearing on thursday.

Thanks, I can see the roads now. However, it doesn’t explain why small slithers aren’t rendered. Can’t even call them rectangles in some places.

@richardbrinkman: Mapnik is not ‘rendered every wednesday’. The mapnik database is continually loaded with new data, and from there new tiles can be generated. It’s just that there are so many tiles to be rendered during a given day, that some requests have to be dropped from the queue to keep the server from overloading.

@Beddhist: where you see a neat horizontal or vertical cutoff on the map, is where you’re seeing the result of 2 tiles which were rendered at different times. One from before your edits, one from after those.

Thanks Ldp, but that still doesn’t explain why there was a very narrow (maybe 200m?) slither of my edit not rendered. I take it the tiles are wider than that? Just curious…


The tiles are square remember, and the data is not. That slither probably crosses the corner of a tile which hasn’t been rendered yet.

I took a look on the links above and it all seems to be rendered at the zoom level you linked to. Admittedly lower zoom levels haven’t but I put in render requests for you (right click and view the image tile then append ‘/dirty’ and it will queue it for rendering).