Auf Garmin etrex Legend Hcx Karten laden, andere Forenlösungen schei

Seit längerem versuche ich – bis jetzt leider total erfolglos – auf mein Garmin etrex Legend Hcx Karten zu laden. So langsam bin ich am verzweifeln….
Ich habe mich u.a. an der OSM Karte von Computerteddy versucht.

  • Karte runtergeladen
  • Auf uSD-Karte den Ordner Garmin angelegt
  • Runtergeladene Karte entpackt und auf SD kopiert
  • In „gmapsupp.img“ umbenannt
  • SD in Garmin gesteckt und neu gestartet
  • Unter Karteneinstellungen ist keine Karte auswählbar (bzw. es ist nur die “normale” Garmin Standartkarte sichtbar)

Beim neu starten des etrex sieht man im unteren Displaybereich einen „Balken“. Es sieht so aus, als würde irgendetwas (vielleicht die Karte) geladen werden. Dieses “laden” erfolgt nur wenn die uSD gesteckt ist.
Habe bereits schon viele Forumlösungen ausprobiert - ohne Erfolg.

Liebe „Experten“ ich dachte immer dass ich keine 2 linken Hände im Bereich Technik hätte. Vielleicht muß ich ja noch irgendwo, irgend etwas machen/auswählen/bestätigen … ???

Vielen Dank im Vorfeld für die Hilfe.


Hope an answer in English is acceptable, else let me know and I will with the risk of being a laughing stock translate it to German,

I have 2 ways to load the maps on my etrex legend HCx, with the use of a Windows XP or Vista PC.

Both processes start the same way
create the map on the Garmin routable map page from Lambertus:

  1. As it should be done
    Download the Mapsource file on your PC
    Run the exe file (Make sure the data end up in the Garmin map, usually not the one which is the default)
    open Mapsource
    select the map (there should now be a map called OSM routable)
    zoom out to you have the full map on your screen
    with the knob map (Select map) select all tiles
    connect your Etrex
    upload the maps to the etrex

should now be available on your system

  1. shorter but you need to know better what you do

down load the
connect the Garmin
create folder called Garmin on the drive
copy the gmapsupp.img to this folder

In both cases you can verify the existence by: selecting map set-up on your Garmin, go to info, it should say OSM World Routable, etc.

Success, Hugo

Wichtig ist an dieser Stelle, dass du die fertige Kartendatei im Garmin-Format (*.img) herunterlädst und nicht Kartendateien für den Einsatz in Mapsource o.ä. - aus letzteren musst du erst in Mapsource eine gmapsupp.img erzeugen, die du dann auf die SD kopieren kannst.

The important bit is to use EITHER ready-to-use Garmin map (*.img) OR the respective file(s) for use in Mapsource etc.
Only the gmapsupp.img can be used if you copied it to \garmin on your device - with all others you need to create the gmapsupp.img in Mapsource first.


I have the very same problem with a Garmin eTrex Venture Cx.

Same effect: When turning the garmin on, a progress bar appears, but the Garmin does not find or list the OSM card as available in any way.

Any other hint?



I found that the progress bar the Garmin shows after turning it on never gets further than 33%

It looks as if the image file generated by Openstreetmap had some sort of syntax or other error causing the Garmin to not accept it.

Well, after upgrading the Garmin from firmware 2.80 to 3.40 the progress bar reaches 67%, but still not 100. Which also implies an incompatibility…

It will never reach 100% as the progress bar isn’t updated when the work is completed. Most of the time I do not see higher percentages than the ones you have seen.

I’ve just downloaded the map from yesterday and it works with my eTrex Vista HCx. If you want to try the same map file, please use

(The address always points to the newest map, so you cannot be sure, that it is the one which worked for me)


I once had a very trivial error, which took me a while to figure out: It turned out that I was compressing the downloaded file instead of decompressing it. Of course the resulting gmapsupp.img did not work. So I finally ended up with a very simple command line that works fine for me now:

wget -O - | bunzip2 > /path/to/my/Garmin/gmapsupp.img

It downloads the newest map, sends it to bunzip2 to unzip it and save it onto the SD card. It works using Linux or Windows, provided you have wget and bunzip2 installed, and give it the correct path to the Garmin folder on your SD card. If you prefer to keep the zipped file, you can also try:

bunzip2 -c gmapsupp.img.bz2 > /path/to/my/Garmin/gmapsupp.img

I’d rather suggest to use 7-zip when working with Windows - it’s free and way easier to use than any command line tools…

But back to Hadmut’s problem: on my Vista HCx w/ 3.10 the progress bar always reaches 100% during startup…

As a Vista owner I don’t know about the peculiarities of the Venture, but the Vista just starts without ever mentioning that it found an OSM map on the card. The only point to tell is in the map menu (and if you see details where the default Garmin map doesn’t have anything)