All favorite points have disappeared from the map in OSM AND app - how to fix it?

Hello. All my favorite points have disappeared from the map in OSM AND app one day (stopped showing up). I had a thousands of them, so I’m very worried. They are still visible on my phone in a OSM folder as files (when connected mobile phone to the computer), but are not displayed on the map. Hovewer, a new favorite points are saved and are visible on the map :frowning: What can I do to restore old favorite points to the map?

I would first recommend backing up your favourites file(s) to your computer before anything else goes wrong.

Have you recently changed the storage location in the app or had an operating system upgrade? Do newly recorded tracks save to the same folder structure as the old favourites file?

If the storage location has changed I think the old favourites might have become “orphaned” in the old folder.

OsmAnd keeps backups of various files inside the OsmAnd directory in a subfolder called “backup”. There you should find files named similar to “favourites_bak_.bz2" or "”, depending on your OsmAnd version. Check if you can recover your favorites from these files.

Thank you for your response.
I remember, that then was some upgrade, but I’m not sure if it was a system or OSMAnd App upgrade. New favourites files are now saved in folder named ‘favourites’, but before the problem appears, files were loose, not collected in any folder. Old favouritesfiles I still have in loose version, but now I can’t copy anything to my computer. When I copy a file and the want to past it on my computer, there this announcement appears: ‘The library, drive, or media pool is empty.’ I also tried to copy one favouritesfile (I have more than one old favouritesfile on my phone) to the favourites folder where are new files collected and I did it, but these favourites points still are not visible on the map.

Thank you for advice.
Unfotunately I can’t copy any file to my computer. When I try to past to my computer any ccopied file, the announcement appears: ‘The library, drive, or media pool is empty.’
You are right, there is a folder “backup” with zipped files. I recognized that the data are recorded from the day when all the files from the map disappeared. Earlier archived files are not here. I have individual files with favorites from before the problem occurred. As a test, I copied one of them to the favorites folder, where new favorites files are now saved automatically, but the application does not see this file and they do not appear on the map.

The message “media pool” suggests to me that what you are trying to do is some sort of “backup” (or restore) rather than a copy?

Perhaps a picture of what you see would help, and more details about the operating system on the computer and the phone?

I’ve just tried the old method - restart computer and plug once again mobile phone. And it worked :wink: I can copy now and I’ve just copied all favourites files.

But…what next?

Maybe try asking the OsmAnd support directly or create a GitHub ticket.