adding a WMS layer in JOSM

I got a link to WMS layer from local government but I got totally no idea how to use it in JOSM. I tried to add it analogically as other WMS layers but it said that the name has to end with ?. I tried to add it to the address but of course with no luck. Can anyone could tell me how to successfully use it in JOSM? Here’s the link to be verified:

Preferences (F11) => WMS/TMS => Press “+” Button
Paste your URL in “Service URL” Filed and add the question mark (?)
Press “Get Layers”
Choos one of them and “Ok”.
Of course you have to be around

Thanks a lot. I couldn’t get layers because now I realized that working on a netbook I couldn’t see the layers that were actually fetched (the window isn’t resizeable!), so it’s really cumbersome to do it on such a small screen. If any devs are reading this - please add option to resize window of adding WMS option.

I’m not an WMS expert but I also use a netbook.
If you rightclick the WMS layer then press “Info” you see “WMS Layer (blah), downloading in zoom 1.62 km”
but the resolution is too small so you only get a “white board”.

If you zoom in (via “+”) and then activate the layer you’ll get “WMS Layer…, downloading in zoom 54.7 m” and it will work.

Another possibiltiy in your case is to use a GIS (e. g. the free quantum gis ( so that you can see the complete map/WMS-Layer
even on an netbook.